diff options
author | Quentin Dufour <quentin@deuxfleurs.fr> | 2021-10-28 10:04:14 +0200 |
---|---|---|
committer | Quentin Dufour <quentin@deuxfleurs.fr> | 2021-10-29 11:34:01 +0200 |
commit | 93f8d59e4c71e6ff2f945dc2c632536f4530b13c (patch) | |
tree | 0d7171fd9c851b87d15bc3705eb394eb612d3ece /shell.nix | |
parent | cc1caa87fbbc11338a650623c7776bf57402cd16 (diff) | |
download | garage-93f8d59e4c71e6ff2f945dc2c632536f4530b13c.tar.gz garage-93f8d59e4c71e6ff2f945dc2c632536f4530b13c.zip |
Extract toolchain build from the CIbug/rust-musl
Diffstat (limited to 'shell.nix')
-rw-r--r-- | shell.nix | 24 |
1 files changed, 22 insertions, 2 deletions
@@ -55,6 +55,13 @@ function refresh_index { result \ s3://garagehq.deuxfleurs.fr/_releases.html } + +function refresh_toolchain { + nix copy \ + --to 's3://nix?endpoint=garage.deuxfleurs.fr®ion=garage&secret-key=/etc/nix/signing-key.sec' \ + $(nix-store -qR \ + $(nix-build --quiet --no-build-output --no-out-link nix/toolchain.nix)) +} ''; nativeBuildInputs = @@ -66,8 +73,21 @@ function refresh_index { /*(pkgs.callPackage cargo2nix {}).package*/ ] else []) ++ - (if integration then [ pkgs.s3cmd pkgs.awscli2 pkgs.minio-client pkgs.rclone pkgs.socat pkgs.psmisc pkgs.which ] else []) + (if integration then [ + pkgs.s3cmd + pkgs.awscli2 + pkgs.minio-client + pkgs.rclone + pkgs.socat + pkgs.psmisc + pkgs.which + pkgs.openssl + pkgs.curl + ] else []) ++ - (if release then [ pkgs.awscli2 kaniko ] else []) + (if release then [ + pkgs.awscli2 + kaniko + ] else []) ; } |