aboutsummaryrefslogtreecommitdiff
path: root/shell.nix
diff options
context:
space:
mode:
authorAlex Auvolat <alex@adnab.me>2023-10-10 13:56:33 +0200
committerAlex Auvolat <alex@adnab.me>2023-10-10 13:56:48 +0200
commitd3fffd30dcf66a9da2e466ae6274547b090313e2 (patch)
tree5d6a025d99823dc9810e0b2876c1566fdf970343 /shell.nix
parente75fe2157d0973eb4320bbc87be5e54a1cb91a63 (diff)
downloadgarage-d3fffd30dcf66a9da2e466ae6274547b090313e2.tar.gz
garage-d3fffd30dcf66a9da2e466ae6274547b090313e2.zip
use mold linker when invoking cargo manually (not in nix build scripts)mold-linker
Diffstat (limited to 'shell.nix')
-rw-r--r--shell.nix21
1 files changed, 11 insertions, 10 deletions
diff --git a/shell.nix b/shell.nix
index 0d510e33..88e292a8 100644
--- a/shell.nix
+++ b/shell.nix
@@ -15,16 +15,17 @@ in {
# --- Rust Shell ---
# Use it to compile Garage
rust = pkgs.mkShell {
- nativeBuildInputs = [
- #pkgs.rustPlatform.rust.rustc
- pkgs.rustPlatform.rust.cargo
- #pkgs.clippy
- pkgs.rustfmt
- #pkgs.perl
- #pkgs.protobuf
- #pkgs.pkg-config
- #pkgs.openssl
- pkgs.file
+ nativeBuildInputs = with pkgs; [
+ #rustPlatform.rust.rustc
+ rustPlatform.rust.cargo
+ mold
+ #clippy
+ rustfmt
+ #perl
+ #protobuf
+ #pkg-config
+ #openssl
+ file
#cargo2nix.packages.x86_64-linux.cargo2nix
];
};