diff options
author | Alex Auvolat <alex@adnab.me> | 2022-10-18 14:19:19 +0200 |
---|---|---|
committer | Alex Auvolat <alex@adnab.me> | 2022-10-18 14:19:19 +0200 |
commit | a54a63c491556b746dab02a0766034af70c61457 (patch) | |
tree | 769c3b645ce600a3ea5d84214f0d38cff022421b /shell.nix | |
parent | 8fc93abc79eb3fa74facda7ca2e8798ff7d01658 (diff) | |
download | garage-a54a63c491556b746dab02a0766034af70c61457.tar.gz garage-a54a63c491556b746dab02a0766034af70c61457.zip |
Add function to upload a build and its dependencies to the cacheupgrade-toolchain
to faster bootstrap new runner nodes
Diffstat (limited to 'shell.nix')
-rw-r--r-- | shell.nix | 12 |
1 files changed, 12 insertions, 0 deletions
@@ -66,6 +66,18 @@ function refresh_toolchain { rm /tmp/nix-signing-key.sec } +function refresh_cache { + pass show deuxfleurs/nix_priv_key > /tmp/nix-signing-key.sec + for attr in clippy.amd64 test.amd64 pkgs.{amd64,i386,arm,arm64}.{debug,release}; do + echo "Updating cache for ''${attr}" + derivation=$(nix-instantiate --attr ''${attr}) + nix copy \ + --to 's3://nix?endpoint=garage.deuxfleurs.fr®ion=garage&secret-key=/tmp/nix-signing-key.sec' \ + $(nix-store -qR ''${derivation%\!bin}) + done + rm /tmp/nix-signing-key.sec +} + function to_s3 { aws \ --endpoint-url https://garage.deuxfleurs.fr \ |