aboutsummaryrefslogtreecommitdiff
path: root/shell.nix
diff options
context:
space:
mode:
authorAlex Auvolat <alex@adnab.me>2024-02-08 15:41:52 +0100
committerAlex Auvolat <alex@adnab.me>2024-02-08 18:24:52 +0100
commit8b6a44a53d0b5b5f61dd597ae8d698a873868305 (patch)
treed48b91f25279cbdf90ba7023da9172e66cf92774 /shell.nix
parent710680da1523921f518d12e19f8a2e27628e2da2 (diff)
downloadgarage-8b6a44a53d0b5b5f61dd597ae8d698a873868305.tar.gz
garage-8b6a44a53d0b5b5f61dd597ae8d698a873868305.zip
[woodpecker] convert drone pipelines to woodpecker
Diffstat (limited to 'shell.nix')
-rw-r--r--shell.nix9
1 files changed, 9 insertions, 0 deletions
diff --git a/shell.nix b/shell.nix
index 991417b5..6d6cc68f 100644
--- a/shell.nix
+++ b/shell.nix
@@ -95,6 +95,15 @@ in {
s3://garagehq.deuxfleurs.fr/_releases/''${DRONE_TAG:-$DRONE_COMMIT}/''${TARGET}/garage
}
+ function to_s3_woodpecker {
+ aws \
+ --endpoint-url https://garage.deuxfleurs.fr \
+ --region garage \
+ s3 cp \
+ ./result-bin/bin/garage \
+ s3://garagehq.deuxfleurs.fr/_releases/''${CI_COMMIT_TAG:-$CI_COMMIT_SHA}/''${TARGET}/garage
+ }
+
function to_docker {
executor \
--force \