aboutsummaryrefslogtreecommitdiff
path: root/shell.nix
diff options
context:
space:
mode:
authorAlex <alex@adnab.me>2024-02-08 17:46:00 +0000
committerAlex <alex@adnab.me>2024-02-08 17:46:00 +0000
commit304a89c57b1e951481cd0bf2e56582b41b6d73e4 (patch)
tree00730627bea8498735d4478844f7cf3064b5078f /shell.nix
parent710680da1523921f518d12e19f8a2e27628e2da2 (diff)
parent25c2f37667eb3b06bb14869129e33f78a9705b1b (diff)
downloadgarage-304a89c57b1e951481cd0bf2e56582b41b6d73e4.tar.gz
garage-304a89c57b1e951481cd0bf2e56582b41b6d73e4.zip
Merge pull request 'convert drone pipelines to woodpecker' (#708) from woodpecker into main
Reviewed-on: https://git.deuxfleurs.fr/Deuxfleurs/garage/pulls/708
Diffstat (limited to 'shell.nix')
-rw-r--r--shell.nix9
1 files changed, 9 insertions, 0 deletions
diff --git a/shell.nix b/shell.nix
index 991417b5..6d6cc68f 100644
--- a/shell.nix
+++ b/shell.nix
@@ -95,6 +95,15 @@ in {
s3://garagehq.deuxfleurs.fr/_releases/''${DRONE_TAG:-$DRONE_COMMIT}/''${TARGET}/garage
}
+ function to_s3_woodpecker {
+ aws \
+ --endpoint-url https://garage.deuxfleurs.fr \
+ --region garage \
+ s3 cp \
+ ./result-bin/bin/garage \
+ s3://garagehq.deuxfleurs.fr/_releases/''${CI_COMMIT_TAG:-$CI_COMMIT_SHA}/''${TARGET}/garage
+ }
+
function to_docker {
executor \
--force \