aboutsummaryrefslogtreecommitdiff
path: root/nix/toolchain.nix
diff options
context:
space:
mode:
authorAlex Auvolat <alex@adnab.me>2023-01-26 12:20:12 +0100
committerAlex Auvolat <alex@adnab.me>2023-01-26 12:25:48 +0100
commitf251b4721f2c016e3a90d913cb766a57a53a3d30 (patch)
treecb4773a8ca81cc9bea205d9b84b3959f8241b4b5 /nix/toolchain.nix
parent1311742fe07ca619d1f37f9f1eabd07ee0d141db (diff)
downloadgarage-f251b4721f2c016e3a90d913cb766a57a53a3d30.tar.gz
garage-f251b4721f2c016e3a90d913cb766a57a53a3d30.zip
Apply nixfmt to all .nix files; fix devshell and add it to cache
Diffstat (limited to 'nix/toolchain.nix')
-rw-r--r--nix/toolchain.nix38
1 files changed, 16 insertions, 22 deletions
diff --git a/nix/toolchain.nix b/nix/toolchain.nix
index 079fcf13..532db74e 100644
--- a/nix/toolchain.nix
+++ b/nix/toolchain.nix
@@ -1,6 +1,4 @@
-{
- system ? builtins.currentSystem,
-}:
+{ system ? builtins.currentSystem, }:
with import ./common.nix;
@@ -11,27 +9,23 @@ let
#"aarch64-unknown-linux-musl"
"armv6l-unknown-linux-musleabihf"
];
- pkgsList = builtins.map (target: import pkgsSrc {
- inherit system;
- crossSystem = {
- config = target;
- isStatic = true;
- };
- overlays = [ cargo2nixOverlay ];
- }) platforms;
- pkgsHost = import pkgsSrc {};
+ pkgsList = builtins.map (target:
+ import pkgsSrc {
+ inherit system;
+ crossSystem = {
+ config = target;
+ isStatic = true;
+ };
+ overlays = [ cargo2nixOverlay ];
+ }) platforms;
+ pkgsHost = import pkgsSrc { };
lib = pkgsHost.lib;
kaniko = (import ./kaniko.nix) pkgsHost;
winscp = (import ./winscp.nix) pkgsHost;
manifestTool = (import ./manifest-tool.nix) pkgsHost;
-in
- lib.flatten (builtins.map (pkgs: [
- pkgs.rustPlatform.rust.rustc
- pkgs.rustPlatform.rust.cargo
- pkgs.buildPackages.stdenv.cc
- ]) pkgsList) ++ [
- kaniko
- winscp
- manifestTool
- ]
+in lib.flatten (builtins.map (pkgs: [
+ pkgs.rustPlatform.rust.rustc
+ pkgs.rustPlatform.rust.cargo
+ pkgs.buildPackages.stdenv.cc
+]) pkgsList) ++ [ kaniko winscp manifestTool ]