aboutsummaryrefslogtreecommitdiff
path: root/flake.nix
diff options
context:
space:
mode:
authorAlex <alex@adnab.me>2023-01-26 15:40:41 +0000
committerAlex <alex@adnab.me>2023-01-26 15:40:41 +0000
commit611792ddcf86f0a728e22abaa6e172d3679d5ca6 (patch)
treea734a4d05cbedfaaff4f3bf63a0b659499b797bb /flake.nix
parent5fb383fe4c248181e27df12a57849886e50bacb7 (diff)
parent94d559ae00bdb899c4463667a9d950b27e5bb23c (diff)
downloadgarage-611792ddcf86f0a728e22abaa6e172d3679d5ca6.tar.gz
garage-611792ddcf86f0a728e22abaa6e172d3679d5ca6.zip
Merge pull request 'Report available disk space in `garage stats`' (#487) from report-disk-usage into main
Reviewed-on: https://git.deuxfleurs.fr/Deuxfleurs/garage/pulls/487
Diffstat (limited to 'flake.nix')
-rw-r--r--flake.nix12
1 files changed, 6 insertions, 6 deletions
diff --git a/flake.nix b/flake.nix
index c1d772bb..7eb9e33b 100644
--- a/flake.nix
+++ b/flake.nix
@@ -1,7 +1,9 @@
{
- description = "Garage, an S3-compatible distributed object store for self-hosted deployments";
+ description =
+ "Garage, an S3-compatible distributed object store for self-hosted deployments";
- inputs.nixpkgs.url = "github:NixOS/nixpkgs/a3073c49bc0163fea6a121c276f526837672b555";
+ inputs.nixpkgs.url =
+ "github:NixOS/nixpkgs/a3073c49bc0163fea6a121c276f526837672b555";
inputs.cargo2nix = {
# As of 2022-10-18: two small patches over unstable branch, one for clippy and one to fix feature detection
url = "github:Alexis211/cargo2nix/a7a61179b66054904ef6a195d8da736eaaa06c36";
@@ -24,13 +26,11 @@
release = true;
}).workspace.garage { compileMode = "build"; };
};
- devShell = ((compile {
+ devShell = (compile {
inherit system git_version;
pkgsSrc = nixpkgs;
cargo2nixOverlay = cargo2nix.overlays.default;
release = false;
- }).workspaceShell {
- packages = [ pkgs.rustfmt cargo2nix.packages.${system}.default ];
- });
+ }).workspaceShell { packages = [ pkgs.rustfmt ]; };
});
}