diff options
author | Alex Auvolat <alex@adnab.me> | 2023-01-26 12:20:12 +0100 |
---|---|---|
committer | Alex Auvolat <alex@adnab.me> | 2023-01-26 12:25:48 +0100 |
commit | f251b4721f2c016e3a90d913cb766a57a53a3d30 (patch) | |
tree | cb4773a8ca81cc9bea205d9b84b3959f8241b4b5 /flake.nix | |
parent | 1311742fe07ca619d1f37f9f1eabd07ee0d141db (diff) | |
download | garage-f251b4721f2c016e3a90d913cb766a57a53a3d30.tar.gz garage-f251b4721f2c016e3a90d913cb766a57a53a3d30.zip |
Apply nixfmt to all .nix files; fix devshell and add it to cache
Diffstat (limited to 'flake.nix')
-rw-r--r-- | flake.nix | 12 |
1 files changed, 6 insertions, 6 deletions
@@ -1,7 +1,9 @@ { - description = "Garage, an S3-compatible distributed object store for self-hosted deployments"; + description = + "Garage, an S3-compatible distributed object store for self-hosted deployments"; - inputs.nixpkgs.url = "github:NixOS/nixpkgs/a3073c49bc0163fea6a121c276f526837672b555"; + inputs.nixpkgs.url = + "github:NixOS/nixpkgs/a3073c49bc0163fea6a121c276f526837672b555"; inputs.cargo2nix = { # As of 2022-10-18: two small patches over unstable branch, one for clippy and one to fix feature detection url = "github:Alexis211/cargo2nix/a7a61179b66054904ef6a195d8da736eaaa06c36"; @@ -24,13 +26,11 @@ release = true; }).workspace.garage { compileMode = "build"; }; }; - devShell = ((compile { + devShell = (compile { inherit system git_version; pkgsSrc = nixpkgs; cargo2nixOverlay = cargo2nix.overlays.default; release = false; - }).workspaceShell { - packages = [ pkgs.rustfmt cargo2nix.packages.${system}.default ]; - }); + }).workspaceShell { packages = [ pkgs.rustfmt ]; }; }); } |