aboutsummaryrefslogtreecommitdiff
path: root/flake.nix
diff options
context:
space:
mode:
authorAlex <alex@adnab.me>2023-10-18 10:02:34 +0000
committerAlex <alex@adnab.me>2023-10-18 10:02:34 +0000
commita5e8ffeb63a193e5b0e020e4c014687e57f85c23 (patch)
tree52351294b31581e0823bafa67b396af627088975 /flake.nix
parentb53510c5b74bc8d52e25bcdb517b38fa60f67a67 (diff)
parentd3fffd30dcf66a9da2e466ae6274547b090313e2 (diff)
downloadgarage-a5e8ffeb63a193e5b0e020e4c014687e57f85c23.tar.gz
garage-a5e8ffeb63a193e5b0e020e4c014687e57f85c23.zip
Merge pull request 'use mold linker when invoking cargo manually (not in nix build scripts)' (#646) from mold-linker into main
Reviewed-on: https://git.deuxfleurs.fr/Deuxfleurs/garage/pulls/646
Diffstat (limited to 'flake.nix')
-rw-r--r--flake.nix5
1 files changed, 4 insertions, 1 deletions
diff --git a/flake.nix b/flake.nix
index 32c01616..f8d7d4df 100644
--- a/flake.nix
+++ b/flake.nix
@@ -48,6 +48,9 @@
pkgsSrc = nixpkgs;
cargo2nixOverlay = cargo2nix.overlays.default;
release = false;
- }).workspaceShell { packages = [ pkgs.rustfmt ]; };
+ }).workspaceShell { packages = with pkgs; [
+ rustfmt
+ mold
+ ]; };
});
}