aboutsummaryrefslogtreecommitdiff
path: root/doc/talks/shell.nix
diff options
context:
space:
mode:
authorAlex <alex@adnab.me>2023-01-20 11:40:08 +0000
committerAlex <alex@adnab.me>2023-01-20 11:40:08 +0000
commit9adf5ca76dc165611a9421ddf49ecb36d02ed754 (patch)
treec2c5e97b40d4d248e30f18b80259922d7d0cb8f3 /doc/talks/shell.nix
parent18bf45061a7548f76e1c7b7b0a92b8ad1609010c (diff)
parent3250be7c48b0789d864e43dc44e238eb7c939500 (diff)
downloadgarage-9adf5ca76dc165611a9421ddf49ecb36d02ed754.tar.gz
garage-9adf5ca76dc165611a9421ddf49ecb36d02ed754.zip
Merge pull request 'Add talk made on 2023-01-18' (#482) from talk-tocatta-2023-01-18 into main
Reviewed-on: https://git.deuxfleurs.fr/Deuxfleurs/garage/pulls/482
Diffstat (limited to 'doc/talks/shell.nix')
-rw-r--r--doc/talks/shell.nix12
1 files changed, 12 insertions, 0 deletions
diff --git a/doc/talks/shell.nix b/doc/talks/shell.nix
new file mode 100644
index 00000000..161a61e1
--- /dev/null
+++ b/doc/talks/shell.nix
@@ -0,0 +1,12 @@
+{ pkgs ? import <nixpkgs> { } }:
+let
+ latex = (pkgs.texlive.combine {
+ inherit (pkgs.texlive)
+ scheme-basic
+ beamer amsmath mathtools breqn
+ environ
+ multirow graphics import adjustbox tabu vwcol stmaryrd ulem ragged2e
+ dvisvgm dvipng wrapfig hyperref capt-of;
+ });
+in pkgs.mkShell { nativeBuildInputs = [ pkgs.gnumake latex ]; }
+