aboutsummaryrefslogtreecommitdiff
path: root/doc/talks/shell.nix
diff options
context:
space:
mode:
authorAlex Auvolat <alex@adnab.me>2023-04-25 12:34:26 +0200
committerAlex Auvolat <alex@adnab.me>2023-04-25 12:34:26 +0200
commitfa78d806e3ae40031e80eebb86e4eb1756d7baea (patch)
tree144662fb430c484093f6f9a585a2441c2ff26494 /doc/talks/shell.nix
parent654999e254e6c1f46bb5d668bc1230f226575716 (diff)
parenta16eb7e4b8344d2f58c09a249b7b1bd17d339a35 (diff)
downloadgarage-fa78d806e3ae40031e80eebb86e4eb1756d7baea.tar.gz
garage-fa78d806e3ae40031e80eebb86e4eb1756d7baea.zip
Merge branch 'main' into next
Diffstat (limited to 'doc/talks/shell.nix')
-rw-r--r--doc/talks/shell.nix12
1 files changed, 12 insertions, 0 deletions
diff --git a/doc/talks/shell.nix b/doc/talks/shell.nix
new file mode 100644
index 00000000..161a61e1
--- /dev/null
+++ b/doc/talks/shell.nix
@@ -0,0 +1,12 @@
+{ pkgs ? import <nixpkgs> { } }:
+let
+ latex = (pkgs.texlive.combine {
+ inherit (pkgs.texlive)
+ scheme-basic
+ beamer amsmath mathtools breqn
+ environ
+ multirow graphics import adjustbox tabu vwcol stmaryrd ulem ragged2e
+ dvisvgm dvipng wrapfig hyperref capt-of;
+ });
+in pkgs.mkShell { nativeBuildInputs = [ pkgs.gnumake latex ]; }
+