aboutsummaryrefslogtreecommitdiff
path: root/default.nix
diff options
context:
space:
mode:
authorAlex Auvolat <alex@adnab.me>2023-01-26 12:20:12 +0100
committerAlex Auvolat <alex@adnab.me>2023-01-26 12:25:48 +0100
commitf251b4721f2c016e3a90d913cb766a57a53a3d30 (patch)
treecb4773a8ca81cc9bea205d9b84b3959f8241b4b5 /default.nix
parent1311742fe07ca619d1f37f9f1eabd07ee0d141db (diff)
downloadgarage-f251b4721f2c016e3a90d913cb766a57a53a3d30.tar.gz
garage-f251b4721f2c016e3a90d913cb766a57a53a3d30.zip
Apply nixfmt to all .nix files; fix devshell and add it to cache
Diffstat (limited to 'default.nix')
-rw-r--r--default.nix28
1 files changed, 11 insertions, 17 deletions
diff --git a/default.nix b/default.nix
index 1791b3c6..ecdf6436 100644
--- a/default.nix
+++ b/default.nix
@@ -1,7 +1,4 @@
-{
- system ? builtins.currentSystem,
- git_version ? null,
-}:
+{ system ? builtins.currentSystem, git_version ? null, }:
with import ./nix/common.nix;
@@ -13,22 +10,21 @@ let
debug = (compile {
inherit system target git_version pkgsSrc cargo2nixOverlay;
release = false;
- }).workspace.garage {
- compileMode = "build";
- };
+ }).workspace.garage { compileMode = "build"; };
release = (compile {
inherit system target git_version pkgsSrc cargo2nixOverlay;
release = true;
- }).workspace.garage {
- compileMode = "build";
- };
+ }).workspace.garage { compileMode = "build"; };
});
- test = (rustPkgs: pkgs.symlinkJoin {
- name ="garage-tests";
- paths = builtins.map (key: rustPkgs.workspace.${key} { compileMode = "test"; }) (builtins.attrNames rustPkgs.workspace);
- });
+ test = (rustPkgs:
+ pkgs.symlinkJoin {
+ name = "garage-tests";
+ paths =
+ builtins.map (key: rustPkgs.workspace.${key} { compileMode = "test"; })
+ (builtins.attrNames rustPkgs.workspace);
+ });
in {
pkgs = {
@@ -55,8 +51,6 @@ in {
inherit system git_version pkgsSrc cargo2nixOverlay;
target = "x86_64-unknown-linux-musl";
compiler = "clippy";
- }).workspace.garage {
- compileMode = "build";
- };
+ }).workspace.garage { compileMode = "build"; };
};
}