aboutsummaryrefslogtreecommitdiff
path: root/default.nix
diff options
context:
space:
mode:
authorAlex Auvolat <alex@adnab.me>2023-01-26 16:46:40 +0100
committerAlex Auvolat <alex@adnab.me>2023-01-26 16:46:40 +0100
commit590a0a84505c0bee8ddd8fcd8de6f340319da097 (patch)
tree14009c0feea6c27cdf36fe85a21dc22753da8653 /default.nix
parentdac254a6e7413498df0e3b626769c2d2be3a4cfb (diff)
parent611792ddcf86f0a728e22abaa6e172d3679d5ca6 (diff)
downloadgarage-590a0a84505c0bee8ddd8fcd8de6f340319da097.tar.gz
garage-590a0a84505c0bee8ddd8fcd8de6f340319da097.zip
Merge branch 'main' into k2v-watch-range-2
Diffstat (limited to 'default.nix')
-rw-r--r--default.nix28
1 files changed, 11 insertions, 17 deletions
diff --git a/default.nix b/default.nix
index 1791b3c6..ecdf6436 100644
--- a/default.nix
+++ b/default.nix
@@ -1,7 +1,4 @@
-{
- system ? builtins.currentSystem,
- git_version ? null,
-}:
+{ system ? builtins.currentSystem, git_version ? null, }:
with import ./nix/common.nix;
@@ -13,22 +10,21 @@ let
debug = (compile {
inherit system target git_version pkgsSrc cargo2nixOverlay;
release = false;
- }).workspace.garage {
- compileMode = "build";
- };
+ }).workspace.garage { compileMode = "build"; };
release = (compile {
inherit system target git_version pkgsSrc cargo2nixOverlay;
release = true;
- }).workspace.garage {
- compileMode = "build";
- };
+ }).workspace.garage { compileMode = "build"; };
});
- test = (rustPkgs: pkgs.symlinkJoin {
- name ="garage-tests";
- paths = builtins.map (key: rustPkgs.workspace.${key} { compileMode = "test"; }) (builtins.attrNames rustPkgs.workspace);
- });
+ test = (rustPkgs:
+ pkgs.symlinkJoin {
+ name = "garage-tests";
+ paths =
+ builtins.map (key: rustPkgs.workspace.${key} { compileMode = "test"; })
+ (builtins.attrNames rustPkgs.workspace);
+ });
in {
pkgs = {
@@ -55,8 +51,6 @@ in {
inherit system git_version pkgsSrc cargo2nixOverlay;
target = "x86_64-unknown-linux-musl";
compiler = "clippy";
- }).workspace.garage {
- compileMode = "build";
- };
+ }).workspace.garage { compileMode = "build"; };
};
}