aboutsummaryrefslogtreecommitdiff
path: root/default.nix
diff options
context:
space:
mode:
authorQuentin Dufour <quentin@deuxfleurs.fr>2022-08-10 12:18:44 +0200
committerAlex Auvolat <alex@adnab.me>2022-08-29 17:54:03 +0200
commitcd5fa90c681c3be7e8835eb4043a55eb5cf01293 (patch)
tree7d0545f849e8548d95ebfae8cde1584b07713bd6 /default.nix
parentd47af7b17300ad9db05ca787ff2038ab50c8b007 (diff)
downloadgarage-cd5fa90c681c3be7e8835eb4043a55eb5cf01293.tar.gz
garage-cd5fa90c681c3be7e8835eb4043a55eb5cf01293.zip
Configure structopt to report the right version
By default, structopt reports the value provided by the env var CARGO_PKG_VERSION, feeded by Cargo when reading Cargo.toml. However for Garage we use a versioning based on git, so we often report a version that is behind the real version. In this commit, we create garage_util::version::garage() that reports the right version and configure all structopt subcommands to call this function instead of using the env var.
Diffstat (limited to 'default.nix')
-rw-r--r--default.nix8
1 files changed, 4 insertions, 4 deletions
diff --git a/default.nix b/default.nix
index 4d7558c5..7e44096c 100644
--- a/default.nix
+++ b/default.nix
@@ -9,8 +9,8 @@ let
pkgs = import pkgsSrc { };
compile = import ./nix/compile.nix;
build_debug_and_release = (target: {
- debug = (compile { inherit target; release = false; }).workspace.garage { compileMode = "build"; };
- release = (compile { inherit target; release = true; }).workspace.garage { compileMode = "build"; };
+ debug = (compile { inherit target git_version; release = false; }).workspace.garage { compileMode = "build"; };
+ release = (compile { inherit target git_version; release = true; }).workspace.garage { compileMode = "build"; };
});
test = (rustPkgs: pkgs.symlinkJoin {
name ="garage-tests";
@@ -25,9 +25,9 @@ in {
arm = build_debug_and_release "armv6l-unknown-linux-musleabihf";
};
test = {
- amd64 = test (compile { target = "x86_64-unknown-linux-musl"; });
+ amd64 = test (compile { inherit git_version; target = "x86_64-unknown-linux-musl"; });
};
clippy = {
- amd64 = (compile { compiler = "clippy"; }).workspace.garage { compileMode = "build"; } ;
+ amd64 = (compile { inherit git_version; compiler = "clippy"; }).workspace.garage { compileMode = "build"; } ;
};
}