diff options
author | Alex Auvolat <alex@adnab.me> | 2020-04-12 19:00:30 +0200 |
---|---|---|
committer | Alex Auvolat <alex@adnab.me> | 2020-04-12 19:00:30 +0200 |
commit | d2814b5c3374f8b99a81dbb9fa3614c875cfc5e6 (patch) | |
tree | 08309e6d85dea5c28f4c12df151ed1b3bdb6bec9 /Cargo.toml | |
parent | d1e8f78b2cd28f4514ad6f7d54aae6aaa4ef3f15 (diff) | |
download | garage-d2814b5c3374f8b99a81dbb9fa3614c875cfc5e6.tar.gz garage-d2814b5c3374f8b99a81dbb9fa3614c875cfc5e6.zip |
TLS works \o/
So, the issues were:
- webpki does not support IP addresses as DNS names in URLs,
so I hacked the HttpsConnector to always provide a fixed string
as the DNS name for server certificate validation
- the certificate requied a SAN section which was complicated to build
but eventually the solution is there in genkeys.sh
Diffstat (limited to 'Cargo.toml')
-rw-r--r-- | Cargo.toml | 6 |
1 files changed, 3 insertions, 3 deletions
@@ -29,11 +29,11 @@ sha2 = "0.8" async-trait = "0.1.30" reduce = "0.1.2" serde_json = "1.0" + rustls = "0.17" -tokio-rustls = "0.13" +tokio-rustls = { version = "0.13", features = ["dangerous_configuration"] } +hyper-rustls = { version = "0.20", default-features = false } webpki = "0.21" -hyper-rustls = "0.20" -#hyper-rustls = { version = "0.4", default-features = false } [profile.dev] lto = "off" |