aboutsummaryrefslogtreecommitdiff
path: root/Cargo.toml
diff options
context:
space:
mode:
authorJakub Jirutka <jakub@jirutka.cz>2022-09-04 15:26:19 +0200
committerJakub Jirutka <jakub@jirutka.cz>2022-09-06 01:14:19 +0200
commitdb72812f01027ab2abd2226a0edaf3161f32e274 (patch)
treeae4369b4d1caf3bc24fd0b7b946c15621343255e /Cargo.toml
parent729a910e14bc44925175ea8240d0c16fdfc18103 (diff)
downloadgarage-db72812f01027ab2abd2226a0edaf3161f32e274.tar.gz
garage-db72812f01027ab2abd2226a0edaf3161f32e274.zip
Use the new cargo feature resolver "2"
Garage currently uses the legacy resolver "1". The new one is used by default if the root package specifies 'edition = 2021', which Garage does not (yet). The problem with the legacy resolver is, among others, that features enabled by dev-dependencies are propagated to normal dependencies. This affects e.g. hyper - one of the dev-dependencies enables "http2" feature that adds many extra dependencies. If we build garage without opentelemetry-otlp (this is enabled in the following commit), there's no normal dependency enabling "http2" feature. See https://doc.rust-lang.org/cargo/reference/resolver.html#feature-resolver-version-2
Diffstat (limited to 'Cargo.toml')
-rw-r--r--Cargo.toml1
1 files changed, 1 insertions, 0 deletions
diff --git a/Cargo.toml b/Cargo.toml
index 122285db..a9fd4423 100644
--- a/Cargo.toml
+++ b/Cargo.toml
@@ -1,4 +1,5 @@
[workspace]
+resolver = "2"
members = [
"src/db",
"src/util",