aboutsummaryrefslogtreecommitdiff
path: root/Cargo.toml
diff options
context:
space:
mode:
authorAlex Auvolat <alex@adnab.me>2024-02-05 18:49:54 +0100
committerAlex Auvolat <alex@adnab.me>2024-02-05 18:49:54 +0100
commit0bb5b77530ad432e4c77f13b395fe74613812337 (patch)
tree9734470cff2ba2ce848abc0fdb9b0032c37420b8 /Cargo.toml
parent6e69a1fffc715c752a399750c1e26aa46683dbb2 (diff)
downloadgarage-0bb5b77530ad432e4c77f13b395fe74613812337.tar.gz
garage-0bb5b77530ad432e4c77f13b395fe74613812337.zip
[dep-upgrade-202402] wip: port to http/hyper crates v1
Diffstat (limited to 'Cargo.toml')
-rw-r--r--Cargo.toml7
1 files changed, 4 insertions, 3 deletions
diff --git a/Cargo.toml b/Cargo.toml
index 0660b449..58b00ee2 100644
--- a/Cargo.toml
+++ b/Cargo.toml
@@ -93,11 +93,12 @@ schemars = "0.8"
reqwest = { version = "0.11", default-features = false, features = ["rustls-tls-manual-roots", "json"] }
form_urlencoded = "1.0.0"
-http = "0.2"
+http = "1.0"
httpdate = "1.0"
http-range = "0.1"
-hyper = { version = "0.14", features = ["server", "http1", "runtime", "tcp", "stream", "backports", "deprecated"] }
-hyperlocal = { version = "0.8.0", default-features = false, features = ["server"] }
+http-body-util = "0.1"
+hyper = { version = "1.0", features = ["server", "http1"] }
+hyper-util = { verion = "0.1", features = [ "full" ]}
multer = "3.0"
percent-encoding = "2.2"
roxmltree = "0.19"