diff options
author | Alex Auvolat <alex@adnab.me> | 2024-03-21 14:06:59 +0100 |
---|---|---|
committer | Alex Auvolat <alex@adnab.me> | 2024-03-26 15:01:34 +0100 |
commit | 74949c69cbf1a8222b6d10a02fcf5fe139ccb560 (patch) | |
tree | 54128ccf24e8598c52c2a5366ad0b509bf1c296e /Cargo.toml | |
parent | 7e0107c47db71e8da13990c9111ebde8cbf60d8f (diff) | |
download | garage-74949c69cbf1a8222b6d10a02fcf5fe139ccb560.tar.gz garage-74949c69cbf1a8222b6d10a02fcf5fe139ccb560.zip |
[s3-checksum] implement x-amz-checksum-* headers
Diffstat (limited to 'Cargo.toml')
-rw-r--r-- | Cargo.toml | 3 |
1 files changed, 3 insertions, 0 deletions
@@ -43,6 +43,8 @@ bytes = "1.0" bytesize = "1.1" cfg-if = "1.0" chrono = "0.4" +crc32fast = "1.4" +crc32c = "0.6" crypto-common = "0.1" digest = "0.10" err-derive = "0.3" @@ -62,6 +64,7 @@ parse_duration = "2.1" pin-project = "1.0.12" pnet_datalink = "0.34" rand = "0.8" +sha1 = "0.10" sha2 = "0.10" timeago = { version = "0.4", default-features = false } xxhash-rust = { version = "0.8", default-features = false, features = ["xxh3"] } |