aboutsummaryrefslogtreecommitdiff
path: root/Cargo.toml
diff options
context:
space:
mode:
authorAlex Auvolat <alex@adnab.me>2020-04-05 23:33:42 +0200
committerAlex Auvolat <alex@adnab.me>2020-04-05 23:33:42 +0200
commit7102db1d544bec663a8492b24c455168d0b83f08 (patch)
treecc308cbeefc3f48b55149e85ec737867c24a498e /Cargo.toml
downloadgarage-7102db1d544bec663a8492b24c455168d0b83f08.tar.gz
garage-7102db1d544bec663a8492b24c455168d0b83f08.zip
First commit: skeleton for something great
Diffstat (limited to 'Cargo.toml')
-rw-r--r--Cargo.toml23
1 files changed, 23 insertions, 0 deletions
diff --git a/Cargo.toml b/Cargo.toml
new file mode 100644
index 00000000..8b170a3a
--- /dev/null
+++ b/Cargo.toml
@@ -0,0 +1,23 @@
+[package]
+name = "garage"
+version = "0.1.0"
+authors = ["Alex Auvolat <alex@adnab.me>"]
+edition = "2018"
+
+# See more keys and their definitions at https://doc.rust-lang.org/cargo/reference/manifest.html
+
+[dependencies]
+bytes = "0.4"
+http = "0.2"
+hyper = "0.13.4"
+kv = "0.20.2"
+futures = "0.3"
+futures-core = "0.3"
+futures-channel = "0.3"
+futures-util = "0.3"
+tokio = { version = "0.2", features = ["full"] }
+serde = { version = "1.0", features = ["derive"] }
+bincode = "1.2.1"
+err-derive = "0.2.3"
+rmp-serde = "0.14.3"
+structopt = { version = "0.3", default-features = false }