diff options
author | Alex Auvolat <alex@adnab.me> | 2024-03-18 17:08:54 +0100 |
---|---|---|
committer | Alex Auvolat <alex@adnab.me> | 2024-03-18 18:05:25 +0100 |
commit | e8f9718ccd656dacc4fba2ed9fa5d8abf12ad37b (patch) | |
tree | 8896fd504d6fc1be97324c1d813309a24bf43e82 /Cargo.toml | |
parent | fd2e19bf1bf301bc03aa29ffa3fe1e71008cbe50 (diff) | |
download | garage-e8f9718ccd656dacc4fba2ed9fa5d8abf12ad37b.tar.gz garage-e8f9718ccd656dacc4fba2ed9fa5d8abf12ad37b.zip |
[sqlite-r2d2] implement connection pooling in sqlite backend
Diffstat (limited to 'Cargo.toml')
-rw-r--r-- | Cargo.toml | 4 |
1 files changed, 3 insertions, 1 deletions
@@ -76,7 +76,9 @@ tracing = "0.1" tracing-subscriber = { version = "0.3", features = ["env-filter"] } heed = { version = "0.11", default-features = false, features = ["lmdb"] } -rusqlite = "0.30.0" +rusqlite = "0.31.0" +r2d2 = "0.8" +r2d2_sqlite = "0.24" sled = "0.34" async-compression = { version = "0.4", features = ["tokio", "zstd"] } |