diff options
author | Alex Auvolat <alex@adnab.me> | 2020-04-21 12:54:55 +0000 |
---|---|---|
committer | Alex Auvolat <alex@adnab.me> | 2020-04-21 12:54:55 +0000 |
commit | cc4f2f1cfb30e3995edf3c1174bd06b4bc0a9bf1 (patch) | |
tree | edf151a855ea4bcc55cad64a959b430e243deffa /Cargo.toml | |
parent | 53cf4d1baaa994544c02ec12f4bea28598720aa8 (diff) | |
download | garage-cc4f2f1cfb30e3995edf3c1174bd06b4bc0a9bf1.tar.gz garage-cc4f2f1cfb30e3995edf3c1174bd06b4bc0a9bf1.zip |
Pretty logging
Diffstat (limited to 'Cargo.toml')
-rw-r--r-- | Cargo.toml | 38 |
1 files changed, 21 insertions, 17 deletions
@@ -8,35 +8,39 @@ edition = "2018" [dependencies] bytes = "0.4" -http = "0.2" -hyper = "0.13" +rand = "0.7" +hex = "0.3" +sha2 = "0.8" +arc-swap = "0.4" +gethostname = "0.2" +err-derive = "0.2.3" +log = "0.4" +pretty_env_logger = "0.4" + sled = "0.31" + +structopt = { version = "0.3", default-features = false } +toml = "0.5" +rmp-serde = "0.14.3" +serde = { version = "1.0", features = ["derive", "rc"] } +serde_bytes = "0.11" +serde_json = "1.0" + +async-trait = "0.1.30" futures = "0.3" futures-core = "0.3" futures-channel = "0.3" futures-util = "0.3" tokio = { version = "0.2", features = ["full"] } -serde = { version = "1.0", features = ["derive", "rc"] } -serde_bytes = "0.11" -bincode = "1.2.1" -err-derive = "0.2.3" -rmp-serde = "0.14.3" -toml = "0.5" -structopt = { version = "0.3", default-features = false } -rand = "0.7" -hex = "0.3" -sha2 = "0.8" -async-trait = "0.1.30" -reduce = "0.1.2" -serde_json = "1.0" -arc-swap = "0.4" -gethostname = "0.2" +http = "0.2" +hyper = "0.13" rustls = "0.17" tokio-rustls = "0.13" hyper-rustls = { version = "0.20", default-features = false } webpki = "0.21" + [profile.dev] lto = "off" |