aboutsummaryrefslogtreecommitdiff
path: root/Cargo.nix
diff options
context:
space:
mode:
authorAlex Auvolat <alex@adnab.me>2023-01-02 15:07:44 +0100
committerAlex Auvolat <alex@adnab.me>2023-01-02 15:07:44 +0100
commit939a6d67e8ace1aa38998281f52511a61f4b4d94 (patch)
treeb94c84bd21ef45e2480c653dc7ed2b37fd5907fb /Cargo.nix
parent6b857a9b8cd454721a2a1e69e108794be07d36a2 (diff)
parent76230f20282e73a5a5afa33af68152acaf732cf5 (diff)
downloadgarage-939a6d67e8ace1aa38998281f52511a61f4b4d94.tar.gz
garage-939a6d67e8ace1aa38998281f52511a61f4b4d94.zip
Merge branch 'main' into internals-reworkinternals-rework
Diffstat (limited to 'Cargo.nix')
-rw-r--r--Cargo.nix120
1 files changed, 60 insertions, 60 deletions
diff --git a/Cargo.nix b/Cargo.nix
index 603a70be..60e48034 100644
--- a/Cargo.nix
+++ b/Cargo.nix
@@ -32,7 +32,7 @@ args@{
ignoreLockHash,
}:
let
- nixifiedLockHash = "a1d84930f23d3d8abc8abbed59b8ce3c9adf9f25d06bc1f39cbdf5bd90aceead";
+ nixifiedLockHash = "4639f63ff4c54c01f66ec3d0d362f6905456dd768d6e94df1a7367c763721fd7";
workspaceSrc = if args.workspaceSrc == null then ./. else args.workspaceSrc;
currentLockHash = builtins.hashFile "sha256" (workspaceSrc + /Cargo.lock);
lockHashIgnored = if ignoreLockHash
@@ -56,15 +56,15 @@ in
{
cargo2nixVersion = "0.11.0";
workspace = {
- garage_db = rustPackages.unknown.garage_db."0.8.0";
- garage_util = rustPackages.unknown.garage_util."0.8.0";
- garage_rpc = rustPackages.unknown.garage_rpc."0.8.0";
- garage_table = rustPackages.unknown.garage_table."0.8.0";
- garage_block = rustPackages.unknown.garage_block."0.8.0";
- garage_model = rustPackages.unknown.garage_model."0.8.0";
- garage_api = rustPackages.unknown.garage_api."0.8.0";
- garage_web = rustPackages.unknown.garage_web."0.8.0";
- garage = rustPackages.unknown.garage."0.8.0";
+ garage_db = rustPackages.unknown.garage_db."0.8.1";
+ garage_util = rustPackages.unknown.garage_util."0.8.1";
+ garage_rpc = rustPackages.unknown.garage_rpc."0.8.1";
+ garage_table = rustPackages.unknown.garage_table."0.8.1";
+ garage_block = rustPackages.unknown.garage_block."0.8.1";
+ garage_model = rustPackages.unknown.garage_model."0.8.1";
+ garage_api = rustPackages.unknown.garage_api."0.8.1";
+ garage_web = rustPackages.unknown.garage_web."0.8.1";
+ garage = rustPackages.unknown.garage."0.8.1";
k2v-client = rustPackages.unknown.k2v-client."0.0.1";
};
"registry+https://github.com/rust-lang/crates.io-index".addr2line."0.17.0" = overridableMkRustCrate (profileName: rec {
@@ -1494,9 +1494,9 @@ in
};
});
- "unknown".garage."0.8.0" = overridableMkRustCrate (profileName: rec {
+ "unknown".garage."0.8.1" = overridableMkRustCrate (profileName: rec {
name = "garage";
- version = "0.8.0";
+ version = "0.8.1";
registry = "unknown";
src = fetchCrateLocal (workspaceSrc + "/src/garage");
features = builtins.concatLists [
@@ -1522,14 +1522,14 @@ in
bytesize = (rustPackages."registry+https://github.com/rust-lang/crates.io-index".bytesize."1.1.0" { inherit profileName; }).out;
futures = (rustPackages."registry+https://github.com/rust-lang/crates.io-index".futures."0.3.21" { inherit profileName; }).out;
futures_util = (rustPackages."registry+https://github.com/rust-lang/crates.io-index".futures-util."0.3.21" { inherit profileName; }).out;
- garage_api = (rustPackages."unknown".garage_api."0.8.0" { inherit profileName; }).out;
- garage_block = (rustPackages."unknown".garage_block."0.8.0" { inherit profileName; }).out;
- garage_db = (rustPackages."unknown".garage_db."0.8.0" { inherit profileName; }).out;
- garage_model = (rustPackages."unknown".garage_model."0.8.0" { inherit profileName; }).out;
- garage_rpc = (rustPackages."unknown".garage_rpc."0.8.0" { inherit profileName; }).out;
- garage_table = (rustPackages."unknown".garage_table."0.8.0" { inherit profileName; }).out;
- garage_util = (rustPackages."unknown".garage_util."0.8.0" { inherit profileName; }).out;
- garage_web = (rustPackages."unknown".garage_web."0.8.0" { inherit profileName; }).out;
+ garage_api = (rustPackages."unknown".garage_api."0.8.1" { inherit profileName; }).out;
+ garage_block = (rustPackages."unknown".garage_block."0.8.1" { inherit profileName; }).out;
+ garage_db = (rustPackages."unknown".garage_db."0.8.1" { inherit profileName; }).out;
+ garage_model = (rustPackages."unknown".garage_model."0.8.1" { inherit profileName; }).out;
+ garage_rpc = (rustPackages."unknown".garage_rpc."0.8.1" { inherit profileName; }).out;
+ garage_table = (rustPackages."unknown".garage_table."0.8.1" { inherit profileName; }).out;
+ garage_util = (rustPackages."unknown".garage_util."0.8.1" { inherit profileName; }).out;
+ garage_web = (rustPackages."unknown".garage_web."0.8.1" { inherit profileName; }).out;
hex = (rustPackages."registry+https://github.com/rust-lang/crates.io-index".hex."0.4.3" { inherit profileName; }).out;
sodiumoxide = (rustPackages."registry+https://github.com/rust-lang/crates.io-index".kuska-sodiumoxide."0.2.5-0" { inherit profileName; }).out;
netapp = (rustPackages."registry+https://github.com/rust-lang/crates.io-index".netapp."0.5.2" { inherit profileName; }).out;
@@ -1563,9 +1563,9 @@ in
};
});
- "unknown".garage_api."0.8.0" = overridableMkRustCrate (profileName: rec {
+ "unknown".garage_api."0.8.1" = overridableMkRustCrate (profileName: rec {
name = "garage_api";
- version = "0.8.0";
+ version = "0.8.1";
registry = "unknown";
src = fetchCrateLocal (workspaceSrc + "/src/api");
features = builtins.concatLists [
@@ -1584,11 +1584,11 @@ in
form_urlencoded = (rustPackages."registry+https://github.com/rust-lang/crates.io-index".form_urlencoded."1.0.1" { inherit profileName; }).out;
futures = (rustPackages."registry+https://github.com/rust-lang/crates.io-index".futures."0.3.21" { inherit profileName; }).out;
futures_util = (rustPackages."registry+https://github.com/rust-lang/crates.io-index".futures-util."0.3.21" { inherit profileName; }).out;
- garage_block = (rustPackages."unknown".garage_block."0.8.0" { inherit profileName; }).out;
- garage_model = (rustPackages."unknown".garage_model."0.8.0" { inherit profileName; }).out;
- garage_rpc = (rustPackages."unknown".garage_rpc."0.8.0" { inherit profileName; }).out;
- garage_table = (rustPackages."unknown".garage_table."0.8.0" { inherit profileName; }).out;
- garage_util = (rustPackages."unknown".garage_util."0.8.0" { inherit profileName; }).out;
+ garage_block = (rustPackages."unknown".garage_block."0.8.1" { inherit profileName; }).out;
+ garage_model = (rustPackages."unknown".garage_model."0.8.1" { inherit profileName; }).out;
+ garage_rpc = (rustPackages."unknown".garage_rpc."0.8.1" { inherit profileName; }).out;
+ garage_table = (rustPackages."unknown".garage_table."0.8.1" { inherit profileName; }).out;
+ garage_util = (rustPackages."unknown".garage_util."0.8.1" { inherit profileName; }).out;
hex = (rustPackages."registry+https://github.com/rust-lang/crates.io-index".hex."0.4.3" { inherit profileName; }).out;
hmac = (rustPackages."registry+https://github.com/rust-lang/crates.io-index".hmac."0.12.1" { inherit profileName; }).out;
http = (rustPackages."registry+https://github.com/rust-lang/crates.io-index".http."0.2.8" { inherit profileName; }).out;
@@ -1617,9 +1617,9 @@ in
};
});
- "unknown".garage_block."0.8.0" = overridableMkRustCrate (profileName: rec {
+ "unknown".garage_block."0.8.1" = overridableMkRustCrate (profileName: rec {
name = "garage_block";
- version = "0.8.0";
+ version = "0.8.1";
registry = "unknown";
src = fetchCrateLocal (workspaceSrc + "/src/block");
features = builtins.concatLists [
@@ -1632,10 +1632,10 @@ in
bytes = (rustPackages."registry+https://github.com/rust-lang/crates.io-index".bytes."1.2.0" { inherit profileName; }).out;
futures = (rustPackages."registry+https://github.com/rust-lang/crates.io-index".futures."0.3.21" { inherit profileName; }).out;
futures_util = (rustPackages."registry+https://github.com/rust-lang/crates.io-index".futures-util."0.3.21" { inherit profileName; }).out;
- garage_db = (rustPackages."unknown".garage_db."0.8.0" { inherit profileName; }).out;
- garage_rpc = (rustPackages."unknown".garage_rpc."0.8.0" { inherit profileName; }).out;
- garage_table = (rustPackages."unknown".garage_table."0.8.0" { inherit profileName; }).out;
- garage_util = (rustPackages."unknown".garage_util."0.8.0" { inherit profileName; }).out;
+ garage_db = (rustPackages."unknown".garage_db."0.8.1" { inherit profileName; }).out;
+ garage_rpc = (rustPackages."unknown".garage_rpc."0.8.1" { inherit profileName; }).out;
+ garage_table = (rustPackages."unknown".garage_table."0.8.1" { inherit profileName; }).out;
+ garage_util = (rustPackages."unknown".garage_util."0.8.1" { inherit profileName; }).out;
hex = (rustPackages."registry+https://github.com/rust-lang/crates.io-index".hex."0.4.3" { inherit profileName; }).out;
opentelemetry = (rustPackages."registry+https://github.com/rust-lang/crates.io-index".opentelemetry."0.17.0" { inherit profileName; }).out;
rand = (rustPackages."registry+https://github.com/rust-lang/crates.io-index".rand."0.8.5" { inherit profileName; }).out;
@@ -1649,9 +1649,9 @@ in
};
});
- "unknown".garage_db."0.8.0" = overridableMkRustCrate (profileName: rec {
+ "unknown".garage_db."0.8.1" = overridableMkRustCrate (profileName: rec {
name = "garage_db";
- version = "0.8.0";
+ version = "0.8.1";
registry = "unknown";
src = fetchCrateLocal (workspaceSrc + "/src/db");
features = builtins.concatLists [
@@ -1681,9 +1681,9 @@ in
};
});
- "unknown".garage_model."0.8.0" = overridableMkRustCrate (profileName: rec {
+ "unknown".garage_model."0.8.1" = overridableMkRustCrate (profileName: rec {
name = "garage_model";
- version = "0.8.0";
+ version = "0.8.1";
registry = "unknown";
src = fetchCrateLocal (workspaceSrc + "/src/model");
features = builtins.concatLists [
@@ -1701,11 +1701,11 @@ in
err_derive = (buildRustPackages."registry+https://github.com/rust-lang/crates.io-index".err-derive."0.3.1" { profileName = "__noProfile"; }).out;
futures = (rustPackages."registry+https://github.com/rust-lang/crates.io-index".futures."0.3.21" { inherit profileName; }).out;
futures_util = (rustPackages."registry+https://github.com/rust-lang/crates.io-index".futures-util."0.3.21" { inherit profileName; }).out;
- garage_block = (rustPackages."unknown".garage_block."0.8.0" { inherit profileName; }).out;
- garage_db = (rustPackages."unknown".garage_db."0.8.0" { inherit profileName; }).out;
- garage_rpc = (rustPackages."unknown".garage_rpc."0.8.0" { inherit profileName; }).out;
- garage_table = (rustPackages."unknown".garage_table."0.8.0" { inherit profileName; }).out;
- garage_util = (rustPackages."unknown".garage_util."0.8.0" { inherit profileName; }).out;
+ garage_block = (rustPackages."unknown".garage_block."0.8.1" { inherit profileName; }).out;
+ garage_db = (rustPackages."unknown".garage_db."0.8.1" { inherit profileName; }).out;
+ garage_rpc = (rustPackages."unknown".garage_rpc."0.8.1" { inherit profileName; }).out;
+ garage_table = (rustPackages."unknown".garage_table."0.8.1" { inherit profileName; }).out;
+ garage_util = (rustPackages."unknown".garage_util."0.8.1" { inherit profileName; }).out;
hex = (rustPackages."registry+https://github.com/rust-lang/crates.io-index".hex."0.4.3" { inherit profileName; }).out;
netapp = (rustPackages."registry+https://github.com/rust-lang/crates.io-index".netapp."0.5.2" { inherit profileName; }).out;
opentelemetry = (rustPackages."registry+https://github.com/rust-lang/crates.io-index".opentelemetry."0.17.0" { inherit profileName; }).out;
@@ -1719,9 +1719,9 @@ in
};
});
- "unknown".garage_rpc."0.8.0" = overridableMkRustCrate (profileName: rec {
+ "unknown".garage_rpc."0.8.1" = overridableMkRustCrate (profileName: rec {
name = "garage_rpc";
- version = "0.8.0";
+ version = "0.8.1";
registry = "unknown";
src = fetchCrateLocal (workspaceSrc + "/src/rpc");
features = builtins.concatLists [
@@ -1741,7 +1741,7 @@ in
${ if rootFeatures' ? "garage/consul-discovery" || rootFeatures' ? "garage_rpc/consul-discovery" || rootFeatures' ? "garage_rpc/err-derive" then "err_derive" else null } = (buildRustPackages."registry+https://github.com/rust-lang/crates.io-index".err-derive."0.3.1" { profileName = "__noProfile"; }).out;
futures = (rustPackages."registry+https://github.com/rust-lang/crates.io-index".futures."0.3.21" { inherit profileName; }).out;
futures_util = (rustPackages."registry+https://github.com/rust-lang/crates.io-index".futures-util."0.3.21" { inherit profileName; }).out;
- garage_util = (rustPackages."unknown".garage_util."0.8.0" { inherit profileName; }).out;
+ garage_util = (rustPackages."unknown".garage_util."0.8.1" { inherit profileName; }).out;
gethostname = (rustPackages."registry+https://github.com/rust-lang/crates.io-index".gethostname."0.2.3" { inherit profileName; }).out;
hex = (rustPackages."registry+https://github.com/rust-lang/crates.io-index".hex."0.4.3" { inherit profileName; }).out;
${ if rootFeatures' ? "garage/kubernetes-discovery" || rootFeatures' ? "garage_rpc/k8s-openapi" || rootFeatures' ? "garage_rpc/kubernetes-discovery" then "k8s_openapi" else null } = (rustPackages."registry+https://github.com/rust-lang/crates.io-index".k8s-openapi."0.16.0" { inherit profileName; }).out;
@@ -1763,9 +1763,9 @@ in
};
});
- "unknown".garage_table."0.8.0" = overridableMkRustCrate (profileName: rec {
+ "unknown".garage_table."0.8.1" = overridableMkRustCrate (profileName: rec {
name = "garage_table";
- version = "0.8.0";
+ version = "0.8.1";
registry = "unknown";
src = fetchCrateLocal (workspaceSrc + "/src/table");
dependencies = {
@@ -1774,9 +1774,9 @@ in
bytes = (rustPackages."registry+https://github.com/rust-lang/crates.io-index".bytes."1.2.0" { inherit profileName; }).out;
futures = (rustPackages."registry+https://github.com/rust-lang/crates.io-index".futures."0.3.21" { inherit profileName; }).out;
futures_util = (rustPackages."registry+https://github.com/rust-lang/crates.io-index".futures-util."0.3.21" { inherit profileName; }).out;
- garage_db = (rustPackages."unknown".garage_db."0.8.0" { inherit profileName; }).out;
- garage_rpc = (rustPackages."unknown".garage_rpc."0.8.0" { inherit profileName; }).out;
- garage_util = (rustPackages."unknown".garage_util."0.8.0" { inherit profileName; }).out;
+ garage_db = (rustPackages."unknown".garage_db."0.8.1" { inherit profileName; }).out;
+ garage_rpc = (rustPackages."unknown".garage_rpc."0.8.1" { inherit profileName; }).out;
+ garage_util = (rustPackages."unknown".garage_util."0.8.1" { inherit profileName; }).out;
hex = (rustPackages."registry+https://github.com/rust-lang/crates.io-index".hex."0.4.3" { inherit profileName; }).out;
hexdump = (rustPackages."registry+https://github.com/rust-lang/crates.io-index".hexdump."0.1.1" { inherit profileName; }).out;
opentelemetry = (rustPackages."registry+https://github.com/rust-lang/crates.io-index".opentelemetry."0.17.0" { inherit profileName; }).out;
@@ -1789,9 +1789,9 @@ in
};
});
- "unknown".garage_util."0.8.0" = overridableMkRustCrate (profileName: rec {
+ "unknown".garage_util."0.8.1" = overridableMkRustCrate (profileName: rec {
name = "garage_util";
- version = "0.8.0";
+ version = "0.8.1";
registry = "unknown";
src = fetchCrateLocal (workspaceSrc + "/src/util");
features = builtins.concatLists [
@@ -1806,7 +1806,7 @@ in
digest = (rustPackages."registry+https://github.com/rust-lang/crates.io-index".digest."0.10.3" { inherit profileName; }).out;
err_derive = (buildRustPackages."registry+https://github.com/rust-lang/crates.io-index".err-derive."0.3.1" { profileName = "__noProfile"; }).out;
futures = (rustPackages."registry+https://github.com/rust-lang/crates.io-index".futures."0.3.21" { inherit profileName; }).out;
- garage_db = (rustPackages."unknown".garage_db."0.8.0" { inherit profileName; }).out;
+ garage_db = (rustPackages."unknown".garage_db."0.8.1" { inherit profileName; }).out;
git_version = (rustPackages."registry+https://github.com/rust-lang/crates.io-index".git-version."0.3.5" { inherit profileName; }).out;
hex = (rustPackages."registry+https://github.com/rust-lang/crates.io-index".hex."0.4.3" { inherit profileName; }).out;
http = (rustPackages."registry+https://github.com/rust-lang/crates.io-index".http."0.2.8" { inherit profileName; }).out;
@@ -1826,18 +1826,18 @@ in
};
});
- "unknown".garage_web."0.8.0" = overridableMkRustCrate (profileName: rec {
+ "unknown".garage_web."0.8.1" = overridableMkRustCrate (profileName: rec {
name = "garage_web";
- version = "0.8.0";
+ version = "0.8.1";
registry = "unknown";
src = fetchCrateLocal (workspaceSrc + "/src/web");
dependencies = {
err_derive = (buildRustPackages."registry+https://github.com/rust-lang/crates.io-index".err-derive."0.3.1" { profileName = "__noProfile"; }).out;
futures = (rustPackages."registry+https://github.com/rust-lang/crates.io-index".futures."0.3.21" { inherit profileName; }).out;
- garage_api = (rustPackages."unknown".garage_api."0.8.0" { inherit profileName; }).out;
- garage_model = (rustPackages."unknown".garage_model."0.8.0" { inherit profileName; }).out;
- garage_table = (rustPackages."unknown".garage_table."0.8.0" { inherit profileName; }).out;
- garage_util = (rustPackages."unknown".garage_util."0.8.0" { inherit profileName; }).out;
+ garage_api = (rustPackages."unknown".garage_api."0.8.1" { inherit profileName; }).out;
+ garage_model = (rustPackages."unknown".garage_model."0.8.1" { inherit profileName; }).out;
+ garage_table = (rustPackages."unknown".garage_table."0.8.1" { inherit profileName; }).out;
+ garage_util = (rustPackages."unknown".garage_util."0.8.1" { inherit profileName; }).out;
http = (rustPackages."registry+https://github.com/rust-lang/crates.io-index".http."0.2.8" { inherit profileName; }).out;
hyper = (rustPackages."registry+https://github.com/rust-lang/crates.io-index".hyper."0.14.18" { inherit profileName; }).out;
opentelemetry = (rustPackages."registry+https://github.com/rust-lang/crates.io-index".opentelemetry."0.17.0" { inherit profileName; }).out;
@@ -2451,7 +2451,7 @@ in
dependencies = {
base64 = (rustPackages."registry+https://github.com/rust-lang/crates.io-index".base64."0.13.0" { inherit profileName; }).out;
${ if rootFeatures' ? "k2v-client/clap" || rootFeatures' ? "k2v-client/cli" then "clap" else null } = (rustPackages."registry+https://github.com/rust-lang/crates.io-index".clap."3.1.18" { inherit profileName; }).out;
- ${ if rootFeatures' ? "k2v-client/cli" || rootFeatures' ? "k2v-client/garage_util" then "garage_util" else null } = (rustPackages."unknown".garage_util."0.8.0" { inherit profileName; }).out;
+ ${ if rootFeatures' ? "k2v-client/cli" || rootFeatures' ? "k2v-client/garage_util" then "garage_util" else null } = (rustPackages."unknown".garage_util."0.8.1" { inherit profileName; }).out;
http = (rustPackages."registry+https://github.com/rust-lang/crates.io-index".http."0.2.8" { inherit profileName; }).out;
log = (rustPackages."registry+https://github.com/rust-lang/crates.io-index".log."0.4.16" { inherit profileName; }).out;
rusoto_core = (rustPackages."registry+https://github.com/rust-lang/crates.io-index".rusoto_core."0.48.0" { inherit profileName; }).out;