aboutsummaryrefslogtreecommitdiff
path: root/Cargo.nix
diff options
context:
space:
mode:
authorAlex Auvolat <alex@adnab.me>2022-12-14 12:58:24 +0100
committerAlex Auvolat <alex@adnab.me>2022-12-14 12:58:24 +0100
commit0d6b05bb6c5a60cfb0a661b994806d35f7c23407 (patch)
tree32935f5757506ca632f88f4ca2233b750ddda554 /Cargo.nix
parenta19bfef508bdcd18773666ab77f85f5a2a9f1388 (diff)
downloadgarage-0d6b05bb6c5a60cfb0a661b994806d35f7c23407.tar.gz
garage-0d6b05bb6c5a60cfb0a661b994806d35f7c23407.zip
Update cargo.nix
Diffstat (limited to 'Cargo.nix')
-rw-r--r--Cargo.nix3
1 files changed, 2 insertions, 1 deletions
diff --git a/Cargo.nix b/Cargo.nix
index 358d2ef0..603a70be 100644
--- a/Cargo.nix
+++ b/Cargo.nix
@@ -32,7 +32,7 @@ args@{
ignoreLockHash,
}:
let
- nixifiedLockHash = "90b29705f5037c7e1b33f4650841f1266f2e86fa03d5d0c87ad80be7619985c7";
+ nixifiedLockHash = "a1d84930f23d3d8abc8abbed59b8ce3c9adf9f25d06bc1f39cbdf5bd90aceead";
workspaceSrc = if args.workspaceSrc == null then ./. else args.workspaceSrc;
currentLockHash = builtins.hashFile "sha256" (workspaceSrc + /Cargo.lock);
lockHashIgnored = if ignoreLockHash
@@ -1769,6 +1769,7 @@ in
registry = "unknown";
src = fetchCrateLocal (workspaceSrc + "/src/table");
dependencies = {
+ arc_swap = (rustPackages."registry+https://github.com/rust-lang/crates.io-index".arc-swap."1.5.0" { inherit profileName; }).out;
async_trait = (buildRustPackages."registry+https://github.com/rust-lang/crates.io-index".async-trait."0.1.52" { profileName = "__noProfile"; }).out;
bytes = (rustPackages."registry+https://github.com/rust-lang/crates.io-index".bytes."1.2.0" { inherit profileName; }).out;
futures = (rustPackages."registry+https://github.com/rust-lang/crates.io-index".futures."0.3.21" { inherit profileName; }).out;