aboutsummaryrefslogtreecommitdiff
path: root/Cargo.nix
diff options
context:
space:
mode:
authorAlex <alex@adnab.me>2023-01-11 16:04:35 +0000
committerAlex <alex@adnab.me>2023-01-11 16:04:35 +0000
commit94d723f27cea7aa58d11af3e18a165283b40f19a (patch)
tree529fa2ca6424a83064551d2de0c8688955baa92d /Cargo.nix
parentbe6b8f419d71640e64bccfe195a573daeeab2263 (diff)
parentd6ea0cbefa6dcf89ea30e1cd2d36854d8160d6b1 (diff)
downloadgarage-94d723f27cea7aa58d11af3e18a165283b40f19a.tar.gz
garage-94d723f27cea7aa58d11af3e18a165283b40f19a.zip
Merge pull request 'Implement `rpc_secret_file`' (#466) from felix.scheinost/garage:feature/implement-rpc-secret-file into main
Reviewed-on: https://git.deuxfleurs.fr/Deuxfleurs/garage/pulls/466
Diffstat (limited to 'Cargo.nix')
-rw-r--r--Cargo.nix5
1 files changed, 4 insertions, 1 deletions
diff --git a/Cargo.nix b/Cargo.nix
index 79601cdd..9ee5b9fb 100644
--- a/Cargo.nix
+++ b/Cargo.nix
@@ -32,7 +32,7 @@ args@{
ignoreLockHash,
}:
let
- nixifiedLockHash = "b6aeefc112eb232904b24398f4e5da776c8ee2c13d427a26dbdf1732205d4fc9";
+ nixifiedLockHash = "8461dcfb984a8d042fecb5745d5da17912135dbf2a8ef7e6c3ae8e64c03d9744";
workspaceSrc = if args.workspaceSrc == null then ./. else args.workspaceSrc;
currentLockHash = builtins.hashFile "sha256" (workspaceSrc + /Cargo.lock);
lockHashIgnored = if ignoreLockHash
@@ -1820,6 +1820,9 @@ in
tracing = (rustPackages."registry+https://github.com/rust-lang/crates.io-index".tracing."0.1.32" { inherit profileName; }).out;
xxhash_rust = (rustPackages."registry+https://github.com/rust-lang/crates.io-index".xxhash-rust."0.8.4" { inherit profileName; }).out;
};
+ devDependencies = {
+ mktemp = (rustPackages."registry+https://github.com/rust-lang/crates.io-index".mktemp."0.4.1" { inherit profileName; }).out;
+ };
});
"unknown".garage_web."0.8.1" = overridableMkRustCrate (profileName: rec {