aboutsummaryrefslogtreecommitdiff
path: root/Cargo.nix
diff options
context:
space:
mode:
authorAlex Auvolat <alex@adnab.me>2023-03-10 18:15:06 +0100
committerAlex Auvolat <alex@adnab.me>2023-03-10 18:15:06 +0100
commit40fa1242f080ba69159607c47f46d47c30267285 (patch)
tree4996774f3b48892260cb58261a0b753c78b8f42f /Cargo.nix
parent9ea154ae9c6b12175192419679ec1bc40da827d1 (diff)
downloadgarage-40fa1242f080ba69159607c47f46d47c30267285.tar.gz
garage-40fa1242f080ba69159607c47f46d47c30267285.zip
update cargo.nix
Diffstat (limited to 'Cargo.nix')
-rw-r--r--Cargo.nix5
1 files changed, 4 insertions, 1 deletions
diff --git a/Cargo.nix b/Cargo.nix
index 642735cf..e11a9b34 100644
--- a/Cargo.nix
+++ b/Cargo.nix
@@ -32,7 +32,7 @@ args@{
ignoreLockHash,
}:
let
- nixifiedLockHash = "9941a539c374cfd67691e633af6c6a5da9e8badbb7b14159b3ff24a7cf5ddf8a";
+ nixifiedLockHash = "0ee5ebe74e19a2d2d3c41b80ed443c93f079f696681902dda4ca659be282d985";
workspaceSrc = if args.workspaceSrc == null then ./. else args.workspaceSrc;
currentLockHash = builtins.hashFile "sha256" (workspaceSrc + /Cargo.lock);
lockHashIgnored = if ignoreLockHash
@@ -1861,6 +1861,9 @@ in
devDependencies = {
mktemp = (rustPackages."registry+https://github.com/rust-lang/crates.io-index".mktemp."0.5.0" { inherit profileName; }).out;
};
+ buildDependencies = {
+ rustc_version = (buildRustPackages."registry+https://github.com/rust-lang/crates.io-index".rustc_version."0.4.0" { profileName = "__noProfile"; }).out;
+ };
});
"unknown".garage_web."0.8.1" = overridableMkRustCrate (profileName: rec {