aboutsummaryrefslogtreecommitdiff
path: root/Cargo.nix
diff options
context:
space:
mode:
authorAlex Auvolat <alex@adnab.me>2023-05-19 12:52:14 +0200
committerAlex Auvolat <alex@adnab.me>2023-05-22 10:45:06 +0200
commite2ce5970c6c1ee26e5aabf6b5dba8d641416fb53 (patch)
treef2aa150a5c11924c442e871b3cd5aa8c42c92886 /Cargo.nix
parent644e8722641c826603f7ee3c2c7b58f31ab88c23 (diff)
downloadgarage-e2ce5970c6c1ee26e5aabf6b5dba8d641416fb53.tar.gz
garage-e2ce5970c6c1ee26e5aabf6b5dba8d641416fb53.zip
Add basic k2v_client integration tests
Diffstat (limited to 'Cargo.nix')
-rw-r--r--Cargo.nix3
1 files changed, 2 insertions, 1 deletions
diff --git a/Cargo.nix b/Cargo.nix
index 014fdcd4..512ec2d5 100644
--- a/Cargo.nix
+++ b/Cargo.nix
@@ -33,7 +33,7 @@ args@{
ignoreLockHash,
}:
let
- nixifiedLockHash = "3d30171172bc39b6c45f9b1917c9eed892c06624b704ac82731524dd9784cbd7";
+ nixifiedLockHash = "269f4ee133812043ba96b2667a7275af385af780a1183c4bd6abaebffb48b521";
workspaceSrc = if args.workspaceSrc == null then ./. else args.workspaceSrc;
currentLockHash = builtins.hashFile "sha256" (workspaceSrc + /Cargo.lock);
lockHashIgnored = if ignoreLockHash
@@ -1737,6 +1737,7 @@ in
hmac = (rustPackages."registry+https://github.com/rust-lang/crates.io-index".hmac."0.12.1" { inherit profileName; }).out;
http = (rustPackages."registry+https://github.com/rust-lang/crates.io-index".http."0.2.9" { inherit profileName; }).out;
hyper = (rustPackages."registry+https://github.com/rust-lang/crates.io-index".hyper."0.14.26" { inherit profileName; }).out;
+ k2v_client = (rustPackages."unknown".k2v-client."0.0.3" { inherit profileName; }).out;
serde_json = (rustPackages."registry+https://github.com/rust-lang/crates.io-index".serde_json."1.0.91" { inherit profileName; }).out;
sha2 = (rustPackages."registry+https://github.com/rust-lang/crates.io-index".sha2."0.10.6" { inherit profileName; }).out;
static_init = (rustPackages."registry+https://github.com/rust-lang/crates.io-index".static_init."1.0.3" { inherit profileName; }).out;