aboutsummaryrefslogtreecommitdiff
path: root/Cargo.nix
diff options
context:
space:
mode:
authorAlex Auvolat <alex@adnab.me>2023-08-28 15:04:18 +0200
committerAlex Auvolat <alex@adnab.me>2023-08-28 17:08:21 +0200
commit06369c8f4abcdedc1ae68e13f1045367674b5b45 (patch)
treee1396dc9ddb11ec6728c3db94f71e349f3db10a8 /Cargo.nix
parentcece1be1bb3aa779b0e01af475572d734c5e51f7 (diff)
downloadgarage-06369c8f4abcdedc1ae68e13f1045367674b5b45.tar.gz
garage-06369c8f4abcdedc1ae68e13f1045367674b5b45.zip
add garage_db dependency in garage_rpcnext-0.8
Diffstat (limited to 'Cargo.nix')
-rw-r--r--Cargo.nix3
1 files changed, 2 insertions, 1 deletions
diff --git a/Cargo.nix b/Cargo.nix
index 3b2700b2..12ef31c6 100644
--- a/Cargo.nix
+++ b/Cargo.nix
@@ -33,7 +33,7 @@ args@{
ignoreLockHash,
}:
let
- nixifiedLockHash = "4d7b9d8135ebc43da8a9353683fc99d626d0f55c895c6ac32bc6e11743088fdf";
+ nixifiedLockHash = "a7a160a4ba7f9e704428eb860ae5c63eae57b2178e4a641d23a43ea1cef9e4a4";
workspaceSrc = if args.workspaceSrc == null then ./. else args.workspaceSrc;
currentLockHash = builtins.hashFile "sha256" (workspaceSrc + /Cargo.lock);
lockHashIgnored = if ignoreLockHash
@@ -1953,6 +1953,7 @@ in
${ if rootFeatures' ? "garage/consul-discovery" || rootFeatures' ? "garage_rpc/consul-discovery" || rootFeatures' ? "garage_rpc/err-derive" then "err_derive" else null } = (buildRustPackages."registry+https://github.com/rust-lang/crates.io-index".err-derive."0.3.1" { profileName = "__noProfile"; }).out;
futures = (rustPackages."registry+https://github.com/rust-lang/crates.io-index".futures."0.3.28" { inherit profileName; }).out;
futures_util = (rustPackages."registry+https://github.com/rust-lang/crates.io-index".futures-util."0.3.28" { inherit profileName; }).out;
+ garage_db = (rustPackages."unknown".garage_db."0.8.3" { inherit profileName; }).out;
garage_util = (rustPackages."unknown".garage_util."0.8.3" { inherit profileName; }).out;
gethostname = (rustPackages."registry+https://github.com/rust-lang/crates.io-index".gethostname."0.4.3" { inherit profileName; }).out;
hex = (rustPackages."registry+https://github.com/rust-lang/crates.io-index".hex."0.4.3" { inherit profileName; }).out;