diff options
author | Alex Auvolat <alex@adnab.me> | 2022-11-08 14:23:08 +0100 |
---|---|---|
committer | Alex Auvolat <alex@adnab.me> | 2022-11-08 14:58:39 +0100 |
commit | d75b37b018fc0ce8e3832c8531d9556ff7a345c9 (patch) | |
tree | bb458446bd8bc8c098beedbebbd4cbefb7359724 /Cargo.nix | |
parent | 73a4ca8b1515f95bf7860fc292c12db83d3c6228 (diff) | |
download | garage-d75b37b018fc0ce8e3832c8531d9556ff7a345c9.tar.gz garage-d75b37b018fc0ce8e3832c8531d9556ff7a345c9.zip |
Return more info when layout's .check() fails, fix compilation, fix test
Diffstat (limited to 'Cargo.nix')
-rw-r--r-- | Cargo.nix | 3 |
1 files changed, 2 insertions, 1 deletions
@@ -32,7 +32,7 @@ args@{ ignoreLockHash, }: let - nixifiedLockHash = "9b1f88c1c5b4639605886c7135957a8fb750d938f789300ba6dae958cae460d9"; + nixifiedLockHash = "a68c589851ec1990d29cdc20e8b922b27c1a6b402b682f7b0d9a9e6258f25828"; workspaceSrc = if args.workspaceSrc == null then ./. else args.workspaceSrc; currentLockHash = builtins.hashFile "sha256" (workspaceSrc + /Cargo.lock); lockHashIgnored = if ignoreLockHash @@ -1736,6 +1736,7 @@ in arc_swap = (rustPackages."registry+https://github.com/rust-lang/crates.io-index".arc-swap."1.5.0" { inherit profileName; }).out; async_trait = (buildRustPackages."registry+https://github.com/rust-lang/crates.io-index".async-trait."0.1.52" { profileName = "__noProfile"; }).out; bytes = (rustPackages."registry+https://github.com/rust-lang/crates.io-index".bytes."1.2.0" { inherit profileName; }).out; + bytesize = (rustPackages."registry+https://github.com/rust-lang/crates.io-index".bytesize."1.1.0" { inherit profileName; }).out; ${ if rootFeatures' ? "garage/consul-discovery" || rootFeatures' ? "garage_rpc/consul-discovery" || rootFeatures' ? "garage_rpc/err-derive" then "err_derive" else null } = (buildRustPackages."registry+https://github.com/rust-lang/crates.io-index".err-derive."0.3.1" { profileName = "__noProfile"; }).out; futures = (rustPackages."registry+https://github.com/rust-lang/crates.io-index".futures."0.3.21" { inherit profileName; }).out; futures_util = (rustPackages."registry+https://github.com/rust-lang/crates.io-index".futures-util."0.3.21" { inherit profileName; }).out; |