aboutsummaryrefslogtreecommitdiff
path: root/Cargo.nix
diff options
context:
space:
mode:
authorAlex <alex@adnab.me>2023-09-11 16:48:14 +0000
committerAlex <alex@adnab.me>2023-09-11 16:48:14 +0000
commitfc635f7072e1def6e45123cd3abc4d267b555fc3 (patch)
tree8e4fa625c3c9ecdc93575ce0bb45ec301ed81227 /Cargo.nix
parent5f86b48f9766019c6c74d14c2fba8c1176423cfb (diff)
parentf8b3883611578713ecb8bcacaf24ca8029e7b739 (diff)
downloadgarage-fc635f7072e1def6e45123cd3abc4d267b555fc3.tar.gz
garage-fc635f7072e1def6e45123cd3abc4d267b555fc3.zip
Merge pull request 'make lmdb's map_size configurable (fix #628)' (#630) from configurable-map-size into main
Reviewed-on: https://git.deuxfleurs.fr/Deuxfleurs/garage/pulls/630
Diffstat (limited to 'Cargo.nix')
-rw-r--r--Cargo.nix3
1 files changed, 2 insertions, 1 deletions
diff --git a/Cargo.nix b/Cargo.nix
index 9e458f88..e57dd49f 100644
--- a/Cargo.nix
+++ b/Cargo.nix
@@ -33,7 +33,7 @@ args@{
ignoreLockHash,
}:
let
- nixifiedLockHash = "b958f9aca0ee3fb1f7b52b15508132d0a96480a7f43f83e0da6609c0fe1812ef";
+ nixifiedLockHash = "3e3f41f614ab470ecb4b06c670cd6a84c443d799d01f1d48f1d251872099c468";
workspaceSrc = if args.workspaceSrc == null then ./. else args.workspaceSrc;
currentLockHash = builtins.hashFile "sha256" (workspaceSrc + /Cargo.lock);
lockHashIgnored = if ignoreLockHash
@@ -2014,6 +2014,7 @@ in
async_trait = (buildRustPackages."registry+https://github.com/rust-lang/crates.io-index".async-trait."0.1.73" { profileName = "__noProfile"; }).out;
blake2 = (rustPackages."registry+https://github.com/rust-lang/crates.io-index".blake2."0.10.6" { inherit profileName; }).out;
bytes = (rustPackages."registry+https://github.com/rust-lang/crates.io-index".bytes."1.4.0" { inherit profileName; }).out;
+ bytesize = (rustPackages."registry+https://github.com/rust-lang/crates.io-index".bytesize."1.3.0" { inherit profileName; }).out;
chrono = (rustPackages."registry+https://github.com/rust-lang/crates.io-index".chrono."0.4.26" { inherit profileName; }).out;
digest = (rustPackages."registry+https://github.com/rust-lang/crates.io-index".digest."0.10.7" { inherit profileName; }).out;
err_derive = (buildRustPackages."registry+https://github.com/rust-lang/crates.io-index".err-derive."0.3.1" { profileName = "__noProfile"; }).out;