aboutsummaryrefslogtreecommitdiff
path: root/Cargo.nix
diff options
context:
space:
mode:
authorAlex Auvolat <alex@adnab.me>2023-08-30 23:47:42 +0200
committerAlex Auvolat <alex@adnab.me>2023-08-30 23:47:42 +0200
commit5fad4c4658676be898186c352f216ca72e0e8601 (patch)
tree7afbd3100918c43febb124e548fa7cd114e7e166 /Cargo.nix
parent01c327a07a6045055fef6f923848fe6046e937c4 (diff)
downloadgarage-5fad4c4658676be898186c352f216ca72e0e8601.tar.gz
garage-5fad4c4658676be898186c352f216ca72e0e8601.zip
update cargo.nix
Diffstat (limited to 'Cargo.nix')
-rw-r--r--Cargo.nix4
1 files changed, 2 insertions, 2 deletions
diff --git a/Cargo.nix b/Cargo.nix
index 645985a8..dc30c355 100644
--- a/Cargo.nix
+++ b/Cargo.nix
@@ -981,7 +981,7 @@ in
[ "iana-time-zone" ]
[ "js-sys" ]
[ "oldtime" ]
- [ "serde" ]
+ (lib.optional (rootFeatures' ? "garage/kubernetes-discovery" || rootFeatures' ? "garage_rpc/k8s-openapi" || rootFeatures' ? "garage_rpc/kube" || rootFeatures' ? "garage_rpc/kubernetes-discovery") "serde")
[ "std" ]
[ "time" ]
[ "wasm-bindgen" ]
@@ -993,7 +993,7 @@ in
${ if hostPlatform.isUnix then "iana_time_zone" else null } = (rustPackages."registry+https://github.com/rust-lang/crates.io-index".iana-time-zone."0.1.57" { inherit profileName; }).out;
${ if hostPlatform.parsed.cpu.name == "wasm32" && !(hostPlatform.parsed.kernel.name == "emscripten" || hostPlatform.parsed.kernel.name == "wasi") then "js_sys" else null } = (rustPackages."registry+https://github.com/rust-lang/crates.io-index".js-sys."0.3.64" { inherit profileName; }).out;
num_traits = (rustPackages."registry+https://github.com/rust-lang/crates.io-index".num-traits."0.2.16" { inherit profileName; }).out;
- serde = (rustPackages."registry+https://github.com/rust-lang/crates.io-index".serde."1.0.188" { inherit profileName; }).out;
+ ${ if rootFeatures' ? "garage/kubernetes-discovery" || rootFeatures' ? "garage_rpc/k8s-openapi" || rootFeatures' ? "garage_rpc/kube" || rootFeatures' ? "garage_rpc/kubernetes-discovery" then "serde" else null } = (rustPackages."registry+https://github.com/rust-lang/crates.io-index".serde."1.0.188" { inherit profileName; }).out;
time = (rustPackages."registry+https://github.com/rust-lang/crates.io-index".time."0.1.45" { inherit profileName; }).out;
${ if hostPlatform.parsed.cpu.name == "wasm32" && !(hostPlatform.parsed.kernel.name == "emscripten" || hostPlatform.parsed.kernel.name == "wasi") then "wasm_bindgen" else null } = (rustPackages."registry+https://github.com/rust-lang/crates.io-index".wasm-bindgen."0.2.87" { inherit profileName; }).out;
${ if hostPlatform.isWindows then "winapi" else null } = (rustPackages."registry+https://github.com/rust-lang/crates.io-index".winapi."0.3.9" { inherit profileName; }).out;