diff options
author | Felix Scheinost <fesc@symentis.com> | 2023-01-07 13:49:15 +0100 |
---|---|---|
committer | Felix Scheinost <fesc@symentis.com> | 2023-01-07 14:19:36 +0100 |
commit | d6ea0cbefa6dcf89ea30e1cd2d36854d8160d6b1 (patch) | |
tree | df97687c1d4b73ec40fe0dd27a3a6a417b483fba /Cargo.nix | |
parent | 7b62fe3f0b1dcb336f153e54e72d8587292aa01b (diff) | |
download | garage-d6ea0cbefa6dcf89ea30e1cd2d36854d8160d6b1.tar.gz garage-d6ea0cbefa6dcf89ea30e1cd2d36854d8160d6b1.zip |
Add tests for `rpc_secret_file`
Diffstat (limited to 'Cargo.nix')
-rw-r--r-- | Cargo.nix | 5 |
1 files changed, 4 insertions, 1 deletions
@@ -32,7 +32,7 @@ args@{ ignoreLockHash, }: let - nixifiedLockHash = "b6aeefc112eb232904b24398f4e5da776c8ee2c13d427a26dbdf1732205d4fc9"; + nixifiedLockHash = "8461dcfb984a8d042fecb5745d5da17912135dbf2a8ef7e6c3ae8e64c03d9744"; workspaceSrc = if args.workspaceSrc == null then ./. else args.workspaceSrc; currentLockHash = builtins.hashFile "sha256" (workspaceSrc + /Cargo.lock); lockHashIgnored = if ignoreLockHash @@ -1820,6 +1820,9 @@ in tracing = (rustPackages."registry+https://github.com/rust-lang/crates.io-index".tracing."0.1.32" { inherit profileName; }).out; xxhash_rust = (rustPackages."registry+https://github.com/rust-lang/crates.io-index".xxhash-rust."0.8.4" { inherit profileName; }).out; }; + devDependencies = { + mktemp = (rustPackages."registry+https://github.com/rust-lang/crates.io-index".mktemp."0.4.1" { inherit profileName; }).out; + }; }); "unknown".garage_web."0.8.1" = overridableMkRustCrate (profileName: rec { |