aboutsummaryrefslogtreecommitdiff
path: root/flake.nix
diff options
context:
space:
mode:
authorAlex Auvolat <alex@adnab.me>2022-12-01 17:38:04 +0100
committerAlex Auvolat <alex@adnab.me>2022-12-01 17:38:04 +0100
commit04528d1e60a6b8757f3eb68f4f42569246d2e3f6 (patch)
tree94485e3bc8574aaaac7d53cbe7b377f90d031373 /flake.nix
parente7f6c15bc11ce04fdc3444f7bd1a588516e92dd9 (diff)
downloaddiplonat-04528d1e60a6b8757f3eb68f4f42569246d2e3f6.tar.gz
diplonat-04528d1e60a6b8757f3eb68f4f42569246d2e3f6.zip
Make repo a nix flake
Diffstat (limited to 'flake.nix')
-rw-r--r--flake.nix36
1 files changed, 36 insertions, 0 deletions
diff --git a/flake.nix b/flake.nix
new file mode 100644
index 0000000..e7781d1
--- /dev/null
+++ b/flake.nix
@@ -0,0 +1,36 @@
+{
+ description = "A very basic flake";
+
+ inputs.nixpkgs.url = "github:NixOS/nixpkgs/a3073c49bc0163fea6a121c276f526837672b555";
+ inputs.cargo2nix = {
+ # As of 2022-10-18: two small patches over unstable branch, one for clippy and one to fix feature detection
+ url = "github:Alexis211/cargo2nix/a7a61179b66054904ef6a195d8da736eaaa06c36";
+ inputs.nixpkgs.follows = "nixpkgs";
+ };
+
+ outputs = { self, nixpkgs, cargo2nix }:
+ let
+ pkgs = import nixpkgs {
+ system = "x86_64-linux";
+ overlays = [ cargo2nix.overlays.default ];
+ };
+ packageFun = import ./Cargo.nix;
+ rustVersion = "1.63.0";
+
+ compile = args: compileMode:
+ let
+ packageSet = pkgs.rustBuilder.makePackageSet ({
+ inherit packageFun rustVersion;
+ } // args);
+ in
+ packageSet.workspace.diplonat {
+ inherit compileMode;
+ };
+ in
+ {
+ test.x86_64-linux.diplonat = compile { release = false; } "test";
+ debug.x86_64-linux.diplonat = compile { release = false; } "build";
+ packages.x86_64-linux.diplonat = compile { release = true; } "build";
+ packages.x86_64-linux.default = self.packages.x86_64-linux.diplonat;
+ };
+}