diff options
author | Alex Auvolat <alex@adnab.me> | 2021-12-25 19:19:19 +0100 |
---|---|---|
committer | Alex Auvolat <alex@adnab.me> | 2021-12-25 19:23:18 +0100 |
commit | 3b9e75634aa06b6df0519e5d44fd6e5281712d09 (patch) | |
tree | d82e14884993895a13cdca78c7388de2e0846f0f /Cargo.toml | |
parent | 4d4d453afa3edafe71db2ae60171b8696b38a3c9 (diff) | |
download | diplonat-3b9e75634aa06b6df0519e5d44fd6e5281712d09.tar.gz diplonat-3b9e75634aa06b6df0519e5d44fd6e5281712d09.zip |
Allow Diplonat to automatically detect it's private IP
Diffstat (limited to 'Cargo.toml')
-rw-r--r-- | Cargo.toml | 7 |
1 files changed, 4 insertions, 3 deletions
@@ -10,13 +10,14 @@ edition = "2018" anyhow = "1.0.28" envy = "0.4" futures = "0.3.5" -igd = { version = "0.10.0", features = ["aio"] } +get_if_addrs = "0.5" +igd = { version = "0.12.0", features = ["aio"] } iptables = "0.2.2" log = "0.4" pretty_env_logger = "0.4" regex = "1" -reqwest = { version = "0.10", features = ["json"] } +reqwest = { version = "0.11", features = ["json"] } serde = { version = "1.0.107", features = ["derive"] } serde-lexpr = "0.1.1" serde_json = "1.0.53" -tokio = "0.2" +tokio = { version = "1", features = ["sync", "rt-multi-thread", "net", "macros"] } |