aboutsummaryrefslogtreecommitdiff
path: root/Cargo.toml
diff options
context:
space:
mode:
authorQuentin <quentin@dufour.io>2021-08-19 08:32:53 +0200
committerQuentin <quentin@dufour.io>2021-08-19 08:32:53 +0200
commitfa25c54e47decf9f323ba0c614f4d9de106626d5 (patch)
tree2f4524b06b95d8522166732feff59e7246fa86e1 /Cargo.toml
parent8b57fb2680673c4ee5a425b262e190fcef724a25 (diff)
parent0f114f21344ddb59f50fed68540c54c41300cf51 (diff)
downloaddiplonat-fa25c54e47decf9f323ba0c614f4d9de106626d5.tar.gz
diplonat-fa25c54e47decf9f323ba0c614f4d9de106626d5.zip
Merge pull request 'Environment parsing done with Serde Envy' (#5) from adrien/diplonat:feature/config-handling into main
Reviewed-on: https://git.deuxfleurs.fr/Deuxfleurs/diplonat/pulls/5
Diffstat (limited to 'Cargo.toml')
-rw-r--r--Cargo.toml15
1 files changed, 8 insertions, 7 deletions
diff --git a/Cargo.toml b/Cargo.toml
index a2a9667..b99d81a 100644
--- a/Cargo.toml
+++ b/Cargo.toml
@@ -7,15 +7,16 @@ edition = "2018"
# See more keys and their definitions at https://doc.rust-lang.org/cargo/reference/manifest.html
[dependencies]
-reqwest = { version = "0.10", features = ["json"] }
+anyhow = "1.0.28"
+envy = "0.4"
+futures = "0.3.5"
igd = { version = "0.10.0", features = ["aio"] }
+iptables = "0.2.2"
log = "0.4"
pretty_env_logger = "0.4"
-tokio = "0.2"
-futures = "0.3.5"
+regex = "1"
+reqwest = { version = "0.10", features = ["json"] }
serde = { version = "1.0.107", features = ["derive"] }
-serde_json = "1.0.53"
serde-lexpr = "0.1.1"
-anyhow = "1.0.28"
-iptables = "0.2.2"
-regex = "1"
+serde_json = "1.0.53"
+tokio = "0.2"