diff options
author | adrien <adrien@luxeylab.net> | 2021-12-28 11:56:12 +0100 |
---|---|---|
committer | adrien <adrien@luxeylab.net> | 2021-12-28 11:56:12 +0100 |
commit | 4560622fa125afb8ac5161f8d0e8a353f99f7a38 (patch) | |
tree | 0e6b8c716955ea5bb5896c5dc4c8294b69e54137 /Cargo.toml | |
parent | 4d4d453afa3edafe71db2ae60171b8696b38a3c9 (diff) | |
parent | 7760b9c58fd98dd934a8f553dd7462049f545cf4 (diff) | |
download | diplonat-4560622fa125afb8ac5161f8d0e8a353f99f7a38.tar.gz diplonat-4560622fa125afb8ac5161f8d0e8a353f99f7a38.zip |
Merge pull request 'Allow Diplonat to automatically detect it's private IP' (#12) from autodetect-private-ip into main
Reviewed-on: https://git.deuxfleurs.fr/Deuxfleurs/diplonat/pulls/12
Diffstat (limited to 'Cargo.toml')
-rw-r--r-- | Cargo.toml | 7 |
1 files changed, 4 insertions, 3 deletions
@@ -10,13 +10,14 @@ edition = "2018" anyhow = "1.0.28" envy = "0.4" futures = "0.3.5" -igd = { version = "0.10.0", features = ["aio"] } +get_if_addrs = "0.5" +igd = { version = "0.12.0", features = ["aio"] } iptables = "0.2.2" log = "0.4" pretty_env_logger = "0.4" regex = "1" -reqwest = { version = "0.10", features = ["json"] } +reqwest = { version = "0.11", features = ["json"] } serde = { version = "1.0.107", features = ["derive"] } serde-lexpr = "0.1.1" serde_json = "1.0.53" -tokio = "0.2" +tokio = { version = "1", features = ["sync", "rt-multi-thread", "net", "macros"] } |