aboutsummaryrefslogtreecommitdiff
path: root/Cargo.toml
diff options
context:
space:
mode:
authorLUXEY Adrien <adrien.luxey@inria.fr>2021-08-14 19:12:18 +0200
committerLUXEY Adrien <adrien.luxey@inria.fr>2021-08-16 10:26:06 +0200
commitae9550ce23bbc85b05669fe5ec4406c8a67417ec (patch)
treebab55a23444b06ded2374dd0380b53a304426b33 /Cargo.toml
parentade0090cdb4a021830439dc0d9a04b2748601ea5 (diff)
downloaddiplonat-ae9550ce23bbc85b05669fe5ec4406c8a67417ec.tar.gz
diplonat-ae9550ce23bbc85b05669fe5ec4406c8a67417ec.zip
New configuration parsing using envy. Added minimal functionnality for
the future ACME parameters. Tests written and passing. WIP: added envy dependncy and ConfigOpts structs that will constitute Diplonat's configuration WIP: ConfigOpts from_env() and validate() methods written. No API change (the env names remain unchanged)! Now need to use our new ConfigOpts struct instead of Environment, and update references to the environment variables in the code. WIP: RuntimeConfig with business logic done. Tests written, but they are all running from the same process - setting environment variables in each test produces incoherent results. Another solution for testing is needed. WIP: tests are fully written using 'from_iter' and all passing
Diffstat (limited to 'Cargo.toml')
-rw-r--r--Cargo.toml15
1 files changed, 8 insertions, 7 deletions
diff --git a/Cargo.toml b/Cargo.toml
index a2a9667..b99d81a 100644
--- a/Cargo.toml
+++ b/Cargo.toml
@@ -7,15 +7,16 @@ edition = "2018"
# See more keys and their definitions at https://doc.rust-lang.org/cargo/reference/manifest.html
[dependencies]
-reqwest = { version = "0.10", features = ["json"] }
+anyhow = "1.0.28"
+envy = "0.4"
+futures = "0.3.5"
igd = { version = "0.10.0", features = ["aio"] }
+iptables = "0.2.2"
log = "0.4"
pretty_env_logger = "0.4"
-tokio = "0.2"
-futures = "0.3.5"
+regex = "1"
+reqwest = { version = "0.10", features = ["json"] }
serde = { version = "1.0.107", features = ["derive"] }
-serde_json = "1.0.53"
serde-lexpr = "0.1.1"
-anyhow = "1.0.28"
-iptables = "0.2.2"
-regex = "1"
+serde_json = "1.0.53"
+tokio = "0.2"