aboutsummaryrefslogtreecommitdiff
path: root/aero-proto/Cargo.toml
diff options
context:
space:
mode:
Diffstat (limited to 'aero-proto/Cargo.toml')
-rw-r--r--aero-proto/Cargo.toml35
1 files changed, 35 insertions, 0 deletions
diff --git a/aero-proto/Cargo.toml b/aero-proto/Cargo.toml
new file mode 100644
index 0000000..df8c696
--- /dev/null
+++ b/aero-proto/Cargo.toml
@@ -0,0 +1,35 @@
+[package]
+name = "aero-proto"
+version = "0.3.0"
+authors = ["Alex Auvolat <alex@adnab.me>", "Quentin Dufour <quentin@dufour.io>"]
+edition = "2021"
+license = "EUPL-1.2"
+description = "Binding between Aerogramme's internal components and well-known protocols"
+
+[dependencies]
+aero-sasl.workspace = true
+aero-dav.workspace = true
+aero-user.workspace = true
+aero-collections.workspace = true
+
+async-trait.workspace = true
+anyhow.workspace = true
+hyper.workspace = true
+base64.workspace = true
+hyper-util.workspace = true
+http-body-util.workspace = true
+futures.workspace = true
+tokio.workspace = true
+tokio-util.workspace = true
+tokio-rustls.workspace = true
+rustls.workspace = true
+rustls-pemfile.workspace = true
+imap-codec.workspace = true
+imap-flow.workspace = true
+chrono.workspace = true
+eml-codec.workspace = true
+thiserror.workspace = true
+duplexify.workspace = true
+smtp-message.workspace = true
+smtp-server.workspace = true
+tracing.workspace = true