aboutsummaryrefslogtreecommitdiff
path: root/flake.nix
diff options
context:
space:
mode:
authorQuentin Dufour <quentin@deuxfleurs.fr>2023-03-13 17:32:23 +0100
committerQuentin Dufour <quentin@deuxfleurs.fr>2023-03-13 17:32:23 +0100
commitf7e041e35ebe588acf6f796f5bb03640619e1c68 (patch)
treedbb9bff8ecce5d1e58cb9192d842de2524abf1b1 /flake.nix
parent736dd54b50bd40d84f86bea2eb7fa66b2fe89d04 (diff)
downloadaerogramme-f7e041e35ebe588acf6f796f5bb03640619e1c68.tar.gz
aerogramme-f7e041e35ebe588acf6f796f5bb03640619e1c68.zip
WIP cargo2nix
Diffstat (limited to 'flake.nix')
-rw-r--r--flake.nix24
1 files changed, 24 insertions, 0 deletions
diff --git a/flake.nix b/flake.nix
new file mode 100644
index 0000000..ec475fa
--- /dev/null
+++ b/flake.nix
@@ -0,0 +1,24 @@
+{
+ description = "Aerogramme";
+
+ inputs = {
+ cargo2nix = {
+ type = "github";
+ owner = "Alexis211";
+ repo = "cargo2nix";
+ ref = "custom_unstable";
+ };
+ };
+
+ outputs = { self, nixpkgs, cargo2nix }: let
+ pkgs = import nixpkgs { system = "x86_64-linux"; };
+ in {
+ devShells.x86_64-linux.default = pkgs.mkShell {
+ buildInputs = [
+ cargo2nix.packages.x86_64-linux.default
+ ];
+ };
+ packages.x86_64-linux.aerogramme = nixpkgs.legacyPackages.x86_64-linux.hello;
+ packages.x86_64-linux.default = self.packages.x86_64-linux.aerogramme;
+ };
+}