aboutsummaryrefslogtreecommitdiff
path: root/Cargo.toml
diff options
context:
space:
mode:
authorQuentin Dufour <quentin@deuxfleurs.fr>2024-02-23 17:31:29 +0100
committerQuentin Dufour <quentin@deuxfleurs.fr>2024-02-23 17:31:29 +0100
commit2a084df300dc30d40cf3599c1cb7a90132d5a6e8 (patch)
tree302175b460a39a4752021d03afd9e7cccda1d56e /Cargo.toml
parent02a8537556236437d905cefe8aa2c5d0a96f129a (diff)
downloadaerogramme-perf/cpu-ram-bottleneck.tar.gz
aerogramme-perf/cpu-ram-bottleneck.zip
Also share HTTPClient for K2Vperf/cpu-ram-bottleneck
Diffstat (limited to 'Cargo.toml')
-rw-r--r--Cargo.toml6
1 files changed, 3 insertions, 3 deletions
diff --git a/Cargo.toml b/Cargo.toml
index 48d1db4..4c10fcc 100644
--- a/Cargo.toml
+++ b/Cargo.toml
@@ -48,15 +48,15 @@ rand = "0.8.5"
rustls = "0.22"
rustls-pemfile = "2.0"
tokio-rustls = "0.25"
-hyper-rustls = { version = "0.24", features = ["http2"] }
-hyper-util = { version = "0.1", features = ["client"] }
+hyper-rustls = { version = "0.26", features = ["http2"] }
+hyper-util = { version = "0.1", features = ["full"] }
rpassword = "7.0"
# login
ldap3 = { version = "0.10", default-features = false, features = ["tls-rustls"] }
# storage
-k2v-client = { git = "https://git.deuxfleurs.fr/Deuxfleurs/garage.git", tag = "v0.9.1" }
+k2v-client = { git = "https://git.deuxfleurs.fr/Deuxfleurs/garage.git", branch = "k2v/shared_http_client" }
aws-config = { version = "1", features = ["behavior-version-latest"] }
aws-sdk-s3 = "1"
aws-smithy-runtime = "1"