diff options
author | Quentin Dufour <quentin@deuxfleurs.fr> | 2024-03-16 16:48:46 +0100 |
---|---|---|
committer | Quentin Dufour <quentin@deuxfleurs.fr> | 2024-03-16 16:48:46 +0100 |
commit | 902d33c4344f4e38c021ff20b2197ee1dfbd347f (patch) | |
tree | 3cea2a5cf9f635eccaa280cd04475e0d580d2eb0 /Cargo.toml | |
parent | 3abdafb0dbbc9290329e4974e821933426b32f91 (diff) | |
download | aerogramme-902d33c4344f4e38c021ff20b2197ee1dfbd347f.tar.gz aerogramme-902d33c4344f4e38c021ff20b2197ee1dfbd347f.zip |
bind streaming codec to hyper 1.x
Diffstat (limited to 'Cargo.toml')
-rw-r--r-- | Cargo.toml | 7 |
1 files changed, 4 insertions, 3 deletions
@@ -24,8 +24,9 @@ aero-proto = { version = "0.3.0", path = "aero-proto" } aerogramme = { version = "0.3.0", path = "aerogramme" } # async runtime -tokio = { version = "1.18", default-features = false, features = ["rt", "rt-multi-thread", "io-util", "net", "time", "macros", "sync", "signal", "fs"] } +tokio = { version = "1.36", default-features = false, features = ["rt", "rt-multi-thread", "io-util", "net", "time", "macros", "sync", "signal", "fs"] } tokio-util = { version = "0.7", features = [ "compat" ] } +tokio-stream = { version = "0.1" } futures = "0.3" # debug @@ -57,8 +58,8 @@ imap-codec = { version = "2.0.0", features = ["bounded-static", "ext_condstore_q imap-flow = { git = "https://github.com/duesee/imap-flow.git", branch = "main" } # http & web -http = "1.0" -http-body-util = "0.1" +http = "1.1" +http-body-util = "0.1.1" hyper = "1.2" hyper-rustls = { version = "0.26", features = ["http2"] } hyper-util = { version = "0.1", features = ["full"] } |