aboutsummaryrefslogtreecommitdiff
path: root/Cargo.toml
diff options
context:
space:
mode:
authorQuentin <quentin@dufour.io>2024-01-25 08:13:03 +0000
committerQuentin <quentin@dufour.io>2024-01-25 08:13:03 +0000
commit1730bd6c10712de3437e2f870a4a7bfc85a23e85 (patch)
treecc1a1cb1165eff5a1b2c73ce15fc74dd770cbf9b /Cargo.toml
parent4eebc2cb7d08570d33251934ae40425dd855aa21 (diff)
parentefd9ae5defd8647b709ad0e6cf17f3b28278c591 (diff)
downloadaerogramme-1730bd6c10712de3437e2f870a4a7bfc85a23e85.tar.gz
aerogramme-1730bd6c10712de3437e2f870a4a7bfc85a23e85.zip
Merge pull request 'feat/finalize-v0.2' (#82) from feat/finalize-v0.2 into main
Reviewed-on: https://git.deuxfleurs.fr/Deuxfleurs/aerogramme/pulls/82
Diffstat (limited to 'Cargo.toml')
-rw-r--r--Cargo.toml9
1 files changed, 7 insertions, 2 deletions
diff --git a/Cargo.toml b/Cargo.toml
index 06eef6f..a02d1a3 100644
--- a/Cargo.toml
+++ b/Cargo.toml
@@ -4,7 +4,7 @@ version = "0.2.0"
authors = ["Alex Auvolat <alex@adnab.me>", "Quentin Dufour <quentin@dufour.io>"]
edition = "2021"
license = "EUPL-1.2"
-description = "Encrypted mail storage over Garage"
+description = "A robust email server"
[dependencies]
# async runtime
@@ -15,6 +15,7 @@ futures = "0.3"
# debug
log = "0.4"
backtrace = "0.3"
+console-subscriber = "0.2"
tracing-subscriber = "0.3"
tracing = "0.1"
@@ -31,18 +32,22 @@ chrono = { version = "0.4", default-features = false, features = ["alloc"] }
nix = { version = "0.27", features = ["signal"] }
clap = { version = "3.1.18", features = ["derive", "env"] }
-# serialization
+# serialization & parsing
serde = "1.0.137"
rmp-serde = "0.15"
toml = "0.5"
base64 = "0.21"
hex = "0.4"
+nom = "7.1"
zstd = { version = "0.9", default-features = false }
# cryptography & security
sodiumoxide = "0.2"
argon2 = "0.5"
rand = "0.8.5"
+rustls = "0.22"
+rustls-pemfile = "2.0"
+tokio-rustls = "0.25"
hyper-rustls = { version = "0.24", features = ["http2"] }
rpassword = "7.0"