diff options
author | Quentin Dufour <quentin@deuxfleurs.fr> | 2024-02-26 23:59:29 +0100 |
---|---|---|
committer | Quentin Dufour <quentin@deuxfleurs.fr> | 2024-02-26 23:59:29 +0100 |
commit | 3d3fd80629c804b0593692318a94dc9f344936fd (patch) | |
tree | 33514ab96c0237ad40227e276a29750d2a05a92b /Cargo.toml | |
parent | 0dcf69f180f5a7b71b6ad2ac67e4cdd81e5154f1 (diff) | |
download | aerogramme-3d3fd80629c804b0593692318a94dc9f344936fd.tar.gz aerogramme-3d3fd80629c804b0593692318a94dc9f344936fd.zip |
Add basic DAV server
Diffstat (limited to 'Cargo.toml')
-rw-r--r-- | Cargo.toml | 29 |
1 files changed, 17 insertions, 12 deletions
@@ -1,6 +1,6 @@ [package] name = "aerogramme" -version = "0.2.2" +version = "0.3.0" authors = ["Alex Auvolat <alex@adnab.me>", "Quentin Dufour <quentin@dufour.io>"] edition = "2021" license = "EUPL-1.2" @@ -18,6 +18,7 @@ backtrace = "0.3" console-subscriber = "0.2" tracing-subscriber = "0.3" tracing = "0.1" +thiserror = "1.0.56" # language extensions lazy_static = "1.4" @@ -32,13 +33,27 @@ chrono = { version = "0.4", default-features = false, features = ["alloc"] } nix = { version = "0.27", features = ["signal"] } clap = { version = "3.1.18", features = ["derive", "env"] } -# serialization & parsing +# email protocols +eml-codec = "0.1.2" +smtp-message = { git = "http://github.com/Alexis211/kannader", branch = "feature/lmtp" } +smtp-server = { git = "http://github.com/Alexis211/kannader", branch = "feature/lmtp" } +imap-codec = { version = "2.0.0", features = ["bounded-static", "ext_condstore_qresync"] } +imap-flow = { git = "https://github.com/duesee/imap-flow.git", branch = "main" } + +# http & web +http-body-util = "0.1" +hyper = "1.2" +hyper-rustls = { version = "0.26", features = ["http2"] } +hyper-util = { version = "0.1", features = ["full"] } + +# serialization, compression & parsing serde = "1.0.137" rmp-serde = "0.15" toml = "0.5" base64 = "0.21" hex = "0.4" nom = "7.1" +quick-xml = "0.31" zstd = { version = "0.9", default-features = false } # cryptography & security @@ -48,8 +63,6 @@ rand = "0.8.5" rustls = "0.22" rustls-pemfile = "2.0" tokio-rustls = "0.25" -hyper-rustls = { version = "0.26", features = ["http2"] } -hyper-util = { version = "0.1", features = ["full"] } rpassword = "7.0" # login @@ -62,14 +75,6 @@ aws-sdk-s3 = "1" aws-smithy-runtime = "1" aws-smithy-runtime-api = "1" -# email protocols -eml-codec = "0.1.2" -smtp-message = { git = "http://github.com/Alexis211/kannader", branch = "feature/lmtp" } -smtp-server = { git = "http://github.com/Alexis211/kannader", branch = "feature/lmtp" } -imap-codec = { version = "2.0.0", features = ["bounded-static", "ext_condstore_qresync"] } -imap-flow = { git = "https://github.com/duesee/imap-flow.git", branch = "main" } -thiserror = "1.0.56" - [dev-dependencies] [patch.crates-io] |