diff options
author | Quentin <quentin@dufour.io> | 2024-02-23 17:32:38 +0000 |
---|---|---|
committer | Quentin <quentin@dufour.io> | 2024-02-23 17:32:38 +0000 |
commit | d92ae5220cdaddf941da5a216fbd2c3549ccdec3 (patch) | |
tree | 464814294b6e50811e0c667cd1430c6855006f8a /Cargo.toml | |
parent | 0bb7cdf696190200d1885ec822518ac45b685a9b (diff) | |
parent | 1ea3de30995b434c4e59123c1ab634d89a0274b5 (diff) | |
download | aerogramme-d92ae5220cdaddf941da5a216fbd2c3549ccdec3.tar.gz aerogramme-d92ae5220cdaddf941da5a216fbd2c3549ccdec3.zip |
Merge pull request 'Perf measurement & bottleneck fix' (#102) from perf/cpu-ram-bottleneck into main0.2.2
Reviewed-on: https://git.deuxfleurs.fr/Deuxfleurs/aerogramme/pulls/102
Diffstat (limited to 'Cargo.toml')
-rw-r--r-- | Cargo.toml | 15 |
1 files changed, 9 insertions, 6 deletions
@@ -1,6 +1,6 @@ [package] name = "aerogramme" -version = "0.2.1" +version = "0.2.2" authors = ["Alex Auvolat <alex@adnab.me>", "Quentin Dufour <quentin@dufour.io>"] edition = "2021" license = "EUPL-1.2" @@ -48,23 +48,26 @@ rand = "0.8.5" rustls = "0.22" rustls-pemfile = "2.0" tokio-rustls = "0.25" -hyper-rustls = { version = "0.24", features = ["http2"] } +hyper-rustls = { version = "0.26", features = ["http2"] } +hyper-util = { version = "0.1", features = ["full"] } rpassword = "7.0" # login ldap3 = { version = "0.10", default-features = false, features = ["tls-rustls"] } # storage -k2v-client = { git = "https://git.deuxfleurs.fr/Deuxfleurs/garage.git", tag = "v0.9.1" } -aws-config = { version = "1.1.1", features = ["behavior-version-latest"] } -aws-sdk-s3 = "1.9.0" +k2v-client = { git = "https://git.deuxfleurs.fr/Deuxfleurs/garage.git", branch = "k2v/shared_http_client" } +aws-config = { version = "1", features = ["behavior-version-latest"] } +aws-sdk-s3 = "1" +aws-smithy-runtime = "1" +aws-smithy-runtime-api = "1" # email protocols eml-codec = "0.1.2" smtp-message = { git = "http://github.com/Alexis211/kannader", branch = "feature/lmtp" } smtp-server = { git = "http://github.com/Alexis211/kannader", branch = "feature/lmtp" } imap-codec = { version = "2.0.0", features = ["bounded-static", "ext_condstore_qresync"] } -imap-flow = { git = "https://github.com/superboum/imap-flow.git", branch = "custom/aerogramme" } +imap-flow = { git = "https://github.com/duesee/imap-flow.git", branch = "main" } thiserror = "1.0.56" [dev-dependencies] |