aboutsummaryrefslogtreecommitdiff
path: root/Cargo.toml
diff options
context:
space:
mode:
authorQuentin Dufour <quentin@deuxfleurs.fr>2023-07-25 10:59:48 +0200
committerQuentin Dufour <quentin@deuxfleurs.fr>2023-07-25 10:59:48 +0200
commit17fba10d8ffe14bb47ae6389dbb28b012eac1b35 (patch)
treee9bb16c769d926985b7e1259626a284dce84d865 /Cargo.toml
parent24fed41288531bf3bf69657eaf3287ff545d0254 (diff)
downloadaerogramme-17fba10d8ffe14bb47ae6389dbb28b012eac1b35.tar.gz
aerogramme-17fba10d8ffe14bb47ae6389dbb28b012eac1b35.zip
replacing mail_parser by eml_codec, first iteration
Diffstat (limited to 'Cargo.toml')
-rw-r--r--Cargo.toml8
1 files changed, 3 insertions, 5 deletions
diff --git a/Cargo.toml b/Cargo.toml
index 4a73eaa..cf0359b 100644
--- a/Cargo.toml
+++ b/Cargo.toml
@@ -14,6 +14,8 @@ backtrace = "0.3"
base64 = "0.13"
clap = { version = "3.1.18", features = ["derive", "env"] }
duplexify = "1.1.0"
+#eml-codec = { path = "../eml-codec" }
+eml-codec = "0.1.0"
hex = "0.4"
futures = "0.3"
im = "15"
@@ -21,7 +23,6 @@ itertools = "0.10"
lazy_static = "1.4"
ldap3 = { version = "0.10", default-features = false, features = ["tls-rustls"] }
log = "0.4"
-mail-parser = "0.8.2"
rusoto_core = { version = "0.48.0", default_features = false, features = ["rustls"] }
rusoto_credential = "0.48.0"
rusoto_s3 = { version = "0.48.0", default_features = false, features = ["rustls"] }
@@ -52,7 +53,4 @@ smtp-server = { git = "http://github.com/Alexis211/kannader", branch = "feature/
#k2v-client = { path = "../garage/src/k2v-client" }
[dev-dependencies]
-#mail-parser-05 = { package = "mail-parser", version = "0.5" }
-#mail-parser-main = { package = "mail-parser", git = "https://github.com/stalwartlabs/mail-parser", branch = "main" }
-#mail-parser-superboum = { package = "mail-parser", git = "https://github.com/superboum/mail-parser", branch = "feature/no_decode" }
-#mail-parser-db61a03 = { package = "mail-parser", git = "https://github.com/superboum/mail-parser", rev = "db61a03" }
+