aboutsummaryrefslogtreecommitdiff
path: root/Cargo.toml
diff options
context:
space:
mode:
authorAlex Auvolat <alex@adnab.me>2022-12-07 15:35:12 +0100
committerAlex Auvolat <alex@adnab.me>2022-12-07 16:09:38 +0100
commited2653ae7dba9c072dcca1aed03b7cda0d910c85 (patch)
tree84452e729d4dbe8c27e3b7b7d4b3160833cfa40e /Cargo.toml
downloadD53-ed2653ae7dba9c072dcca1aed03b7cda0d910c85.tar.gz
D53-ed2653ae7dba9c072dcca1aed03b7cda0d910c85.zip
First version of D53 that does something
First working version
Diffstat (limited to 'Cargo.toml')
-rw-r--r--Cargo.toml19
1 files changed, 19 insertions, 0 deletions
diff --git a/Cargo.toml b/Cargo.toml
new file mode 100644
index 0000000..cbdf4e3
--- /dev/null
+++ b/Cargo.toml
@@ -0,0 +1,19 @@
+[package]
+name = "d53"
+description = "D53 is a dynamic DNS updater that sources information from Consul to route services to the correct place"
+version = "0.1.0"
+edition = "2021"
+
+# See more keys and their definitions at https://doc.rust-lang.org/cargo/reference/manifest.html
+
+[dependencies]
+async-trait = "0.1"
+anyhow = "1.0.66"
+futures = "0.3"
+log = "0.4"
+pretty_env_logger = "0.4"
+df-consul = "0.1.0"
+structopt = "0.3"
+tokio = { version = "1.22", default-features = false, features = ["rt", "rt-multi-thread", "io-util", "net", "time", "macros", "sync", "signal", "fs"] }
+reqwest = { version = "0.11", default-features = false, features = ["json", "rustls-tls-webpki-roots" ] }
+serde = { version = "1.0.107", features = ["derive"] }